summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_8.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_8.12.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.12.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.12.bb b/meta/recipes-core/coreutils/coreutils_8.12.bb
new file mode 100644
index 0000000000..00746b908a
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_8.12.bb
@@ -0,0 +1,76 @@
1SUMMARY = "The basic file, shell and text manipulation utilities."
2DESCRIPTION = "The GNU Core Utilities provide the basic file, shell and text \
3manipulation utilities. These are the core utilities which are expected to exist on \
4every system."
5HOMEPAGE = "http://www.gnu.org/software/coreutils/"
6BUGTRACKER = "http://debbugs.gnu.org/coreutils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
9 file://src/ls.c;startline=5;endline=16;md5=e1a509558876db58fb6667ba140137ad"
10PR = "r2"
11DEPENDS = "gmp"
12DEPENDS_virtclass-native = ""
13
14inherit autotools gettext
15
16SRC_URI = "${GNU_MIRROR}/coreutils/${BP}.tar.gz"
17
18SRC_URI[md5sum] = "fce7999953a67243d00d75cc86dbcaa6"
19SRC_URI[sha256sum] = "9e233a62c98a3378a7b0483d2ae3d662dbaf6cd3917d3830d3514665e12a85c8"
20
21EXTRA_OECONF_virtclass-native = "--without-gmp"
22
23# [ gets a special treatment and is not included in this
24bindir_progs = "base64 basename chcon cksum comm csplit cut dir dircolors dirname du \
25 env expand expr factor fmt fold groups head hostid id install \
26 join link logname md5sum mkfifo mktemp nice nl nohup nproc od paste pathchk \
27 pinky pr printenv printf ptx readlink runcon seq sha1sum sha224sum sha256sum \
28 sha384sum sha512sum shred shuf sort split stat stdbuf sum tac tail tee test timeout\
29 tr truncate tsort tty unexpand uniq unlink uptime users vdir wc who whoami yes"
30
31# hostname gets a special treatment and is not included in this
32base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
33 mknod mv pwd rm rmdir sleep stty sync touch true uname"
34
35sbindir_progs= "chroot"
36
37do_install_append() {
38 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
39
40 install -d ${D}${base_bindir}
41 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
42
43 install -d ${D}${sbindir}
44 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
45
46 # [ requires special handling because [.coreutils will cause the sed stuff
47 # in update-alternatives to fail, therefore use lbracket - the name used
48 # for the actual source file.
49 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
50}
51
52pkg_postinst_${PN} () {
53 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
54
55 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
56
57 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
58
59 # Special cases. [ needs to be treated separately.
60 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
61}
62
63pkg_prerm_${PN} () {
64 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
65
66 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
67
68 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
69
70 # The special cases
71 update-alternatives --remove hostname hostname.${PN}
72 update-alternatives --remove uptime uptime.${PN}
73 update-alternatives --remove '[' 'lbracket.${PN}'
74}
75
76BBCLASSEXTEND = "native"