summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils_6.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils_6.9.bb')
-rw-r--r--meta/recipes-core/coreutils/coreutils_6.9.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_6.9.bb b/meta/recipes-core/coreutils/coreutils_6.9.bb
new file mode 100644
index 0000000000..6a23f4f65f
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils_6.9.bb
@@ -0,0 +1,78 @@
1DESCRIPTION = "The GNU Core Utilities are the basic file, shell and text manipulation utilities of the GNU operating system. These are the core utilities which are expected to exist on every operating system"
2HOMEPAGE = "http://www.gnu.org/software/coreutils/"
3BUGTRACKER = "http://debbugs.gnu.org/coreutils"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
6 file://src/ls.c;startline=4;endline=16;md5=482a96d4f25010a4e13f8743e0c3685e"
7PR = "r0"
8DEPENDS = "perl-native"
9
10inherit autotools gettext
11
12SRC_URI = "http://ftp.gnu.org/gnu/coreutils/${BP}.tar.bz2 \
13 file://gnulib_m4.patch \
14 file://futimens.patch \
15 file://man-touch.patch"
16
17# [ gets a special treatment and is not included in this
18bindir_progs = "base64 basename cksum comm csplit cut dir dircolors dirname du \
19 env expand expr factor fmt fold groups head hostid id install \
20 join link logname md5sum mkfifo nice nl nohup od paste pathchk \
21 pinky pr printenv printf ptx readlink seq sha1sum sha224sum sha256sum \
22 sha384sum sha512sum shred shuf sort split stat sum tac tail tee test \
23 tr tsort tty unexpand uniq unlink users vdir wc who whoami yes"
24
25# hostname gets a special treatment and is not included in this
26base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill ln ls mkdir \
27 mknod mv pwd rm rmdir sleep stty sync touch true uname"
28
29sbindir_progs= "chroot"
30
31do_install() {
32 autotools_do_install
33
34 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
35
36 install -d ${D}${base_bindir}
37 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
38
39 install -d ${D}${sbindir}
40 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
41
42 # [ requires special handling because [.coreutils will cause the sed stuff
43 # in update-alternatives to fail, therefore use lbracket - the name used
44 # for the actual source file.
45 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
46
47 # hostname and uptime separated. busybox's versions are preferred
48 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
49 mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
50}
51
52pkg_postinst_${PN} () {
53 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
54
55 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
56
57 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
58
59 # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
60 update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
61 update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
62 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
63}
64
65pkg_prerm_${PN} () {
66 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
67
68 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
69
70 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
71
72 # The special cases
73 update-alternatives --remove hostname hostname.${PN}
74 update-alternatives --remove uptime uptime.${PN}
75 update-alternatives --remove '[' 'lbracket.${PN}'
76}
77
78BBCLASSEXTEND = "native"