summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/console-tools/console-tools_0.3.2.bb')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb27
1 files changed, 5 insertions, 22 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
index 5f1d640a2d..6027d4abd1 100644
--- a/meta/recipes-core/console-tools/console-tools_0.3.2.bb
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9" 3LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
4SUMMARY = "Allows you to set-up and manipulate the Linux console." 4SUMMARY = "Allows you to set-up and manipulate the Linux console."
5DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files." 5DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
6PR = "r4" 6PR = "r5"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \ 8SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
9 file://codepage.patch \ 9 file://codepage.patch \
@@ -30,28 +30,11 @@ do_compile () {
30 oe_runmake 'SUBDIRS=${SUBDIRS}' 30 oe_runmake 'SUBDIRS=${SUBDIRS}'
31} 31}
32 32
33inherit autotools gettext 33inherit autotools gettext update-alternatives
34 34
35do_install () { 35ALTERNATIVE_PRIORITY = "100"
36 autotools_do_install
37 mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
38 mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
39 mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
40 mv ${D}${bindir}/fgconsole ${D}${bindir}/fgconsole.${PN}
41}
42
43pkg_postinst_${PN} () {
44 update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
45 update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
46 update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
47 update-alternatives --install ${bindir}/fgconsole fgconsole fgconsole.${PN} 100
48}
49 36
50pkg_prerm_${PN} () { 37bindir_progs = "chvt deallocvt fgconsole openvt"
51 update-alternatives --remove chvt chvt.${PN} 38ALTERNATIVE_LINKS = "${bindir}/${@' ${bindir}/'.join((d.getVar('bindir_progs', True)).split())}"
52 update-alternatives --remove deallocvt deallocvt.${PN}
53 update-alternatives --remove openvt openvt.${PN}
54 update-alternatives --remove fgconsole fgconsole.${PN}
55}
56 39
57RDEPENDS_${PN} = "bash" 40RDEPENDS_${PN} = "bash"