summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools/console-tools_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/console-tools/console-tools_0.3.2.bb')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
new file mode 100644
index 0000000000..c60a5a05bb
--- /dev/null
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -0,0 +1,37 @@
1SECTION = "base"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
4SUMMARY = "Allows you to set-up and manipulate the Linux console"
5DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
6PR = "r8"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
9 file://codepage.patch \
10 file://configure.patch \
11 file://compile.patch \
12 file://kbdrate.patch \
13 file://uclibc-fileno.patch \
14 file://nodocs.patch \
15 file://fix-libconsole-linking.patch \
16 file://no-dep-on-libfl.patch \
17 file://lcmessage.m4 \
18 file://Makevars"
19
20SRC_URI[md5sum] = "bf21564fc38b3af853ef724babddbacd"
21SRC_URI[sha256sum] = "eea6b441672dacd251079fc85ed322e196282e0e66c16303ec64c3a2b1c126c2"
22
23do_configure_prepend () {
24 mkdir -p ${S}/m4
25 cp ${WORKDIR}/lcmessage.m4 ${S}/m4/
26 rm -f ${S}/acinclude.m4
27 cp ${WORKDIR}/Makevars ${S}/po/
28}
29
30inherit autotools gettext update-alternatives
31
32ALTERNATIVE_PRIORITY = "100"
33
34bindir_progs = "chvt deallocvt fgconsole openvt"
35ALTERNATIVE_${PN} = "${bindir_progs}"
36
37RDEPENDS_${PN} = "bash"