summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/busybox/busybox_git.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
new file mode 100644
index 0000000000..f2cc119400
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -0,0 +1,46 @@
1require busybox.inc
2
3SRCREV = "d9e0c438e10e2155513e5d26498af472c5137d65"
4# Lookout for PV bump too when SRCREV is changed
5PV = "1.22.1+git${SRCPV}"
6
7S = "${WORKDIR}/git"
8
9SRC_URI = "git://busybox.net/busybox.git \
10 file://get_header_tar.patch \
11 file://busybox-appletlib-dependency.patch \
12 file://busybox-udhcpc-no_deconfig.patch \
13 file://find-touchscreen.sh \
14 file://busybox-cron \
15 file://busybox-httpd \
16 file://busybox-udhcpd \
17 file://default.script \
18 file://simple.script \
19 file://hwclock.sh \
20 file://mount.busybox \
21 file://syslog \
22 file://syslog-startup.conf \
23 file://syslog.conf \
24 file://busybox-syslog.default \
25 file://mdev \
26 file://mdev.conf \
27 file://umount.busybox \
28 file://defconfig \
29 file://busybox-syslog.service.in \
30 file://busybox-klogd.service.in \
31 file://fail_on_no_media.patch \
32 file://run-ptest \
33 file://inetd.conf \
34 file://inetd \
35 file://login-utilities.cfg \
36"
37
38EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
39
40do_install_ptest () {
41 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
42 cp ${B}/.config ${D}${PTEST_PATH}/
43 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
44}
45
46DEFAULT_PREFERENCE = "-1"