summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.22.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.22.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
new file mode 100644
index 0000000000..1b1eaf35ac
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -0,0 +1,50 @@
1require busybox.inc
2
3PR = "r32"
4
5SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
6 file://get_header_tar.patch \
7 file://busybox-appletlib-dependency.patch \
8 file://busybox-udhcpc-no_deconfig.patch \
9 file://find-touchscreen.sh \
10 file://busybox-cron \
11 file://busybox-httpd \
12 file://busybox-udhcpd \
13 file://default.script \
14 file://simple.script \
15 file://hwclock.sh \
16 file://mount.busybox \
17 file://syslog \
18 file://syslog-startup.conf \
19 file://syslog.conf \
20 file://busybox-syslog.default \
21 file://mdev \
22 file://mdev.conf \
23 file://umount.busybox \
24 file://defconfig \
25 file://busybox-syslog.service.in \
26 file://busybox-klogd.service.in \
27 file://fail_on_no_media.patch \
28 file://run-ptest \
29 file://inetd.conf \
30 file://inetd \
31 file://login-utilities.cfg \
32 file://0001-build-system-Specify-nostldlib-when-linking-to-.o-fi.patch \
33 file://recognize_connmand.patch \
34 file://busybox-cross-menuconfig.patch \
35 file://CVE-2014-9645_busybox_reject_module_names_with_slashes.patch \
36 file://lzop-add-overflow-check.patch \
37 file://libarchive-open_zipped-does-not-need-to-check-extens.patch \
38 file://unbreak_noncompressed_tar.patch \
39"
40
41SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"
42SRC_URI[tarball.sha256sum] = "ae0b029d0a9e4dd71a077a790840e496dd838998e4571b87b60fed7462b6678b"
43
44EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
45
46do_install_ptest () {
47 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
48 cp ${B}/.config ${D}${PTEST_PATH}/
49 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
50}