summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.21.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.21.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.21.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.21.1.bb b/meta/recipes-core/busybox/busybox_1.21.1.bb
new file mode 100644
index 0000000000..5c0527397e
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.21.1.bb
@@ -0,0 +1,47 @@
1require busybox.inc
2PR = "r0"
3
4SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
5 file://get_header_tar.patch \
6 file://busybox-appletlib-dependency.patch \
7 file://run-parts.in.usr-bin.patch \
8 file://watch.in.usr-bin.patch \
9 file://busybox-udhcpc-no_deconfig.patch \
10 file://find-touchscreen.sh \
11 file://busybox-cron \
12 file://busybox-httpd \
13 file://busybox-udhcpd \
14 file://default.script \
15 file://simple.script \
16 file://hwclock.sh \
17 file://mount.busybox \
18 file://syslog \
19 file://syslog-startup.conf \
20 file://syslog.conf \
21 file://busybox-syslog.default \
22 file://mdev \
23 file://mdev.conf \
24 file://umount.busybox \
25 file://defconfig \
26 file://stat-usr-bin.patch \
27 file://busybox-syslog.service.in \
28 file://busybox-klogd.service.in \
29 file://testsuite-du-du-k-works-fix-false-positive.patch \
30 file://fail_on_no_media.patch \
31 file://busybox-sulogin-empty-root-password.patch \
32 file://run-ptest \
33 file://inetd.conf \
34 file://inetd \
35 file://login-utilities.cfg \
36 file://busybox-list-suid-and-non-suid-app-configs.patch"
37
38SRC_URI[tarball.md5sum] = "795394f83903b5eec6567d51eebb417e"
39SRC_URI[tarball.sha256sum] = "cd5be0912ec856110ae12c76c3ec9cd5cba1df45b5a9da2b095b8284d1481303"
40
41EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
42
43do_install_ptest () {
44 cp -r ${B}/testsuite ${D}${PTEST_PATH}/
45 cp ${B}/.config ${D}${PTEST_PATH}/
46 ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
47}