summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/base-passwd/base-passwd_3.5.29.bb')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.29.bb29
1 files changed, 10 insertions, 19 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
index 10457b2dec..e43bc0a007 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.29.bb
@@ -23,8 +23,6 @@ UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/b/base-passwd/"
23 23
24inherit autotools 24inherit autotools
25 25
26SSTATEPOSTINSTFUNCS += "base_passwd_sstate_postinst"
27
28do_install () { 26do_install () {
29 install -d -m 755 ${D}${sbindir} 27 install -d -m 755 ${D}${sbindir}
30 install -o root -g root -p -m 755 ${B}/update-passwd ${D}${sbindir}/ 28 install -o root -g root -p -m 755 ${B}/update-passwd ${D}${sbindir}/
@@ -45,23 +43,16 @@ do_install () {
45 install -p -m 644 ${S}/debian/copyright ${D}${docdir}/${BPN}/ 43 install -p -m 644 ${S}/debian/copyright ${D}${docdir}/${BPN}/
46} 44}
47 45
48base_passwd_sstate_postinst() { 46SYSROOT_DIRS += "${sysconfdir}"
49 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ] 47SYSROOT_PREPROCESS_FUNCS += "base_passwd_tweaksysroot"
50 then 48
51 # Staging does not copy ${sysconfdir} files into the 49base_passwd_tweaksysroot () {
52 # target sysroot, so we need to do so manually. We 50 # Install passwd.master and group.master to sysconfdir
53 # put these files in the target sysroot so they can 51 install -d -m 755 ${SYSROOT_DESTDIR}${sysconfdir}
54 # be used by recipes which use custom user/group 52 for i in passwd group; do
55 # permissions. 53 install -p -m 644 ${SYSROOT_DESTDIR}${datadir}/base-passwd/$i.master \
56 # Install passwd.master and group.master to sysconfdir and mv 54 ${SYSROOT_DESTDIR}${sysconfdir}/$i
57 # them to make sure they are atomically install. 55 done
58 install -d -m 755 ${STAGING_DIR_TARGET}${sysconfdir}
59 for i in passwd group; do
60 install -p -m 644 ${STAGING_DIR_TARGET}${datadir}/base-passwd/$i.master \
61 ${STAGING_DIR_TARGET}${sysconfdir}/
62 mv ${STAGING_DIR_TARGET}${sysconfdir}/$i.master ${STAGING_DIR_TARGET}${sysconfdir}/$i
63 done
64 fi
65} 56}
66 57
67python populate_packages_prepend() { 58python populate_packages_prepend() {