summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb')
-rw-r--r--meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb b/meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
new file mode 100644
index 0000000000..17167022b9
--- /dev/null
+++ b/meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Telepathy IM framework - Python package"
2HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
5 file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822"
6
7DEPENDS = "libxslt-native"
8RDEPENDS_${PN} += "python-dbus"
9
10SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
11 file://parallel_make.patch \
12 file://remove_duplicate_install.patch \
13 file://telepathy-python_fix_for_automake_1.12.patch"
14
15PR = "r6"
16
17inherit autotools pythonnative
18
19SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
20SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
21
22FILES_${PN} += "\
23 ${libdir}/python*/site-packages/telepathy/*.py \
24 ${libdir}/python*/site-packages/telepathy/*/*.py \
25 "
26
27do_install_append () {
28 rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyc
29 rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyo
30 rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyc
31 rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyo
32}