summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.2.2.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.2.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.2.2.bb b/meta/recipes-connectivity/socat/socat_1.7.2.2.bb
new file mode 100644
index 0000000000..f015def60a
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.2.2.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Socat is a relay for bidirectional data \
2transfer between two independent data channels."
3HOMEPAGE = "http://www.dest-unreach.org/socat/"
4
5SECTION = "console/network"
6
7DEPENDS = "openssl readline"
8
9LICENSE = "GPL-2.0+-with-OpenSSL-exception"
10LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760 \
11 file://README;beginline=252;endline=282;md5=79246f11a1db0b6ccec54d1fb711c01e"
12
13
14SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
15 file://compile.patch \
16 file://fix-xxx_SHIFT-autoheader.patch"
17
18SRC_URI[md5sum] = "39231e512d8052f328552865df15d42f"
19SRC_URI[sha256sum] = "9a167af11a4d3809cbc66f5e2dcb39b6e371251282ef5de6ea6ff0c4be8a953c"
20
21PACKAGECONFIG ??= "tcp-wrappers"
22PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
23
24EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \
25 sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \
26 ac_cv_ispeed_offset=13 \
27"
28
29inherit autotools
30
31do_configure_prepend() {
32 sed '/AC_DEFINE_UNQUOTED(ISPEED_OFFSET/a\AC_DEFINE(OSPEED_OFFSET,\
33(ISPEED_OFFSET+1)\ ,\ [have\ ospeed\ offset])' -i ${S}/configure.in
34}
35
36do_install_prepend () {
37 mkdir -p ${D}${bindir}
38 install -d ${D}${bindir} ${D}${mandir}/man1
39}