diff options
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.92.bb')
-rw-r--r-- | meta/recipes-connectivity/resolvconf/resolvconf_1.92.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.92.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.92.bb new file mode 100644 index 0000000000..226cb7ee77 --- /dev/null +++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.92.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "name server information handler" | ||
2 | DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \ | ||
3 | information about currently available nameservers. It sets \ | ||
4 | itself up as the intermediary between programs that supply \ | ||
5 | nameserver information and programs that need nameserver \ | ||
6 | information." | ||
7 | SECTION = "console/network" | ||
8 | LICENSE = "GPL-2.0-or-later" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" | ||
10 | HOMEPAGE = "http://packages.debian.org/resolvconf" | ||
11 | RDEPENDS:${PN} = "bash sed util-linux-flock" | ||
12 | |||
13 | SRC_URI = "git://salsa.debian.org/debian/resolvconf.git;protocol=https;branch=unstable \ | ||
14 | file://99_resolvconf \ | ||
15 | file://0001-avoid-using-m-option-for-readlink.patch \ | ||
16 | " | ||
17 | |||
18 | SRCREV = "86047276c80705c51859a19f0c472102e0822f34" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | # the package is taken from snapshots.debian.org; that source is static and goes stale | ||
23 | # so we check the latest upstream from a directory that does get updated | ||
24 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/" | ||
25 | |||
26 | do_compile () { | ||
27 | : | ||
28 | } | ||
29 | |||
30 | do_install () { | ||
31 | install -d ${D}${sysconfdir}/default/volatiles | ||
32 | install -m 0644 ${WORKDIR}/99_resolvconf ${D}${sysconfdir}/default/volatiles | ||
33 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
34 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
35 | echo "d /run/${BPN}/interface - - - -" \ | ||
36 | > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
37 | fi | ||
38 | install -d ${D}${base_libdir}/${BPN} | ||
39 | install -d ${D}${sysconfdir}/${BPN} | ||
40 | install -d ${D}${nonarch_base_libdir}/${BPN} | ||
41 | ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run | ||
42 | install -d ${D}${sysconfdir} ${D}${base_sbindir} | ||
43 | install -d ${D}${mandir}/man8 ${D}${docdir}/${P} | ||
44 | cp -pPR etc/resolvconf ${D}${sysconfdir}/ | ||
45 | chown -R root:root ${D}${sysconfdir}/ | ||
46 | install -m 0755 bin/resolvconf ${D}${base_sbindir}/ | ||
47 | install -m 0755 bin/normalize-resolvconf ${D}${nonarch_base_libdir}/${BPN} | ||
48 | install -m 0755 bin/list-records ${D}${base_libdir}/${BPN} | ||
49 | install -d ${D}/${sysconfdir}/network/if-up.d | ||
50 | install -m 0755 debian/resolvconf.000resolvconf.if-up ${D}/${sysconfdir}/network/if-up.d/000resolvconf | ||
51 | install -d ${D}/${sysconfdir}/network/if-down.d | ||
52 | install -m 0755 debian/resolvconf.resolvconf.if-down ${D}/${sysconfdir}/network/if-down.d/resolvconf | ||
53 | install -m 0644 README ${D}${docdir}/${P}/ | ||
54 | install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/ | ||
55 | } | ||
56 | |||
57 | pkg_postinst:${PN} () { | ||
58 | if [ -z "$D" ]; then | ||
59 | if command -v systemd-tmpfiles >/dev/null; then | ||
60 | systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
61 | elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then | ||
62 | ${sysconfdir}/init.d/populate-volatile.sh update | ||
63 | fi | ||
64 | fi | ||
65 | } | ||
66 | |||
67 | FILES:${PN} += "${base_libdir}/${BPN} ${nonarch_base_libdir}/${BPN}" | ||