diff options
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.76.bb')
-rw-r--r-- | meta/recipes-connectivity/resolvconf/resolvconf_1.76.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.76.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.76.bb new file mode 100644 index 0000000000..eb29a2a06a --- /dev/null +++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.76.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | SUMMARY = "name server information handler" | ||
2 | DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \ | ||
3 | information about currently available nameservers. It sets \ | ||
4 | itself up as the intermediary between programs that supply \ | ||
5 | nameserver information and programs that need nameserver \ | ||
6 | information." | ||
7 | SECTION = "console/network" | ||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" | ||
10 | AUTHOR = "Thomas Hood" | ||
11 | HOMEPAGE = "http://packages.debian.org/resolvconf" | ||
12 | RDEPENDS_${PN} = "bash" | ||
13 | |||
14 | SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.xz" | ||
15 | |||
16 | SRC_URI[md5sum] = "d78ce30ea068999cd3e0523300b27255" | ||
17 | SRC_URI[sha256sum] = "c9f40f7405b37399ddbf29ca4205b4911ee35cb9ffd9be7671faa2385b1fa573" | ||
18 | |||
19 | inherit allarch | ||
20 | |||
21 | do_compile () { | ||
22 | : | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -d ${D}${sysconfdir}/default/volatiles | ||
27 | echo "d root root 0755 ${localstatedir}/run/${BPN}/interface none" \ | ||
28 | > ${D}${sysconfdir}/default/volatiles/99_resolvconf | ||
29 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
30 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
31 | echo "d /run/${BPN}/interface - - - -" \ | ||
32 | > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
33 | fi | ||
34 | install -d ${D}${sysconfdir}/${BPN} | ||
35 | ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run | ||
36 | install -d ${D}${sysconfdir} ${D}${base_sbindir} | ||
37 | install -d ${D}${mandir}/man8 ${D}${docdir}/${P} | ||
38 | cp -pPR etc/* ${D}${sysconfdir}/ | ||
39 | chown -R root:root ${D}${sysconfdir}/ | ||
40 | install -m 0755 bin/resolvconf ${D}${base_sbindir}/ | ||
41 | install -m 0644 README ${D}${docdir}/${P}/ | ||
42 | install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/ | ||
43 | } | ||
44 | |||
45 | pkg_postinst_${PN} () { | ||
46 | if [ -z "$D" ]; then | ||
47 | if command -v systemd-tmpfiles >/dev/null; then | ||
48 | systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf | ||
49 | elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then | ||
50 | ${sysconfdir}/init.d/populate-volatile.sh update | ||
51 | fi | ||
52 | fi | ||
53 | } | ||