summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb')
-rw-r--r--meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb
new file mode 100644
index 0000000000..5897e40489
--- /dev/null
+++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.74.bb
@@ -0,0 +1,53 @@
1SUMMARY = "name server information handler"
2DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \
3information about currently available nameservers. It sets \
4itself up as the intermediary between programs that supply \
5nameserver information and programs that need nameserver \
6information."
7SECTION = "console/network"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10AUTHOR = "Thomas Hood"
11HOMEPAGE = "http://packages.debian.org/resolvconf"
12RDEPENDS_${PN} = "bash"
13
14SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
15
16SRC_URI[md5sum] = "2f190d3bb8960b69157f63590c262e93"
17SRC_URI[sha256sum] = "2e72e6884e9105cbf57101ab0f11e768717b6f76b7f5100c6a2a0cc69bb3d4a0"
18
19inherit allarch
20
21do_compile () {
22 :
23}
24
25do_install () {
26 install -d ${D}${sysconfdir}/default/volatiles
27 echo "d root root 0755 ${localstatedir}/run/${BPN}/interface none" \
28 > ${D}${sysconfdir}/default/volatiles/99_resolvconf
29 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
30 install -d ${D}${sysconfdir}/tmpfiles.d
31 echo "d /run/${BPN}/interface - - - -" \
32 > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf
33 fi
34 install -d ${D}${sysconfdir}/${BPN}
35 ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run
36 install -d ${D}${sysconfdir} ${D}${base_sbindir}
37 install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
38 cp -pPR etc/* ${D}${sysconfdir}/
39 chown -R root:root ${D}${sysconfdir}/
40 install -m 0755 bin/resolvconf ${D}${base_sbindir}/
41 install -m 0644 README ${D}${docdir}/${P}/
42 install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
43}
44
45pkg_postinst_${PN} () {
46 if [ -z "$D" ]; then
47 if command -v systemd-tmpfiles >/dev/null; then
48 systemd-tmpfiles --create ${sysconfdir}/tmpfiles.d/resolvconf.conf
49 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
50 ${sysconfdir}/init.d/populate-volatile.sh update
51 fi
52 fi
53}