summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb')
-rw-r--r--meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb
new file mode 100644
index 0000000000..c924fe07d8
--- /dev/null
+++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.61.bb
@@ -0,0 +1,34 @@
1SUMMARY = "name server information handler"
2DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \
3information about currently available nameservers. It sets \
4itself up as the intermediary between programs that supply \
5nameserver information and programs that need nameserver \
6information."
7SECTION = "console/network"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10AUTHOR = "Thomas Hood"
11HOMEPAGE = "http://packages.debian.org/resolvconf"
12RDEPENDS_${PN} = "bash"
13PR = "r0"
14
15SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
16
17SRC_URI[md5sum] = "ac1cfa1abc7c690f1d8917f746ad80a5"
18SRC_URI[sha256sum] = "0eaa97fa29f8e30a541d549abe76766e5e4edfa841721529c85616d7c0089908"
19
20inherit allarch
21
22do_compile () {
23 :
24}
25
26do_install () {
27 install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${base_sbindir} ${D}${localstatedir}/volatile/run/resolvconf/interface
28 install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
29 cp -pPR etc/* ${D}${sysconfdir}/
30 chown -R root:root ${D}${sysconfdir}/
31 install -m 0755 bin/resolvconf ${D}${base_sbindir}/
32 install -m 0644 README ${D}${docdir}/${P}/
33 install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
34}