summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb')
-rw-r--r--meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
new file mode 100644
index 0000000000..94231e0af6
--- /dev/null
+++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.59.bb
@@ -0,0 +1,36 @@
1SUMMARY = "name server information handler"
2DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \
3information about currently available nameservers. It sets \
4itself up as the intermediary between programs that supply \
5nameserver information and programs that need nameserver \
6information."
7SECTION = "console/network"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
10AUTHOR = "Thomas Hood"
11HOMEPAGE = "http://packages.debian.org/resolvconf"
12DEPENDS = "bash"
13RDEPENDS_${PN} = "bash"
14PR = "r0"
15
16SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
17
18SRC_URI[md5sum] = "59b20258bb8a3c25b8c4083fc0279547"
19SRC_URI[sha256sum] = "37691677cea24da66d6664c98668b5f16667c0133f17feb166f246ee923ad756"
20
21do_compile () {
22 :
23}
24
25do_install () {
26 install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${base_sbindir} ${D}${localstatedir}/volatile/run/resolvconf/interface
27 install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
28 cp -pPR etc/* ${D}${sysconfdir}/
29 chown -R root:root ${D}${sysconfdir}/
30 install -m 0755 bin/resolvconf ${D}${base_sbindir}/
31 install -m 0644 README ${D}${docdir}/${P}/
32 install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
33}
34
35PACKAGE_ARCH = "all"
36