diff options
Diffstat (limited to 'meta/recipes-connectivity/ppp/ppp_2.4.9.bb')
-rw-r--r-- | meta/recipes-connectivity/ppp/ppp_2.4.9.bb | 95 |
1 files changed, 95 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp/ppp_2.4.9.bb b/meta/recipes-connectivity/ppp/ppp_2.4.9.bb new file mode 100644 index 0000000000..f05f40dd06 --- /dev/null +++ b/meta/recipes-connectivity/ppp/ppp_2.4.9.bb | |||
@@ -0,0 +1,95 @@ | |||
1 | SUMMARY = "Point-to-Point Protocol (PPP) support" | ||
2 | DESCRIPTION = "ppp (Paul's PPP Package) is an open source package which implements \ | ||
3 | the Point-to-Point Protocol (PPP) on Linux and Solaris systems." | ||
4 | SECTION = "console/network" | ||
5 | HOMEPAGE = "http://samba.org/ppp/" | ||
6 | BUGTRACKER = "http://ppp.samba.org/cgi-bin/ppp-bugs" | ||
7 | DEPENDS = "libpcap openssl virtual/crypt" | ||
8 | LICENSE = "BSD & GPLv2+ & LGPLv2+ & PD" | ||
9 | LIC_FILES_CHKSUM = "file://pppd/ccp.c;beginline=1;endline=29;md5=e2c43fe6e81ff77d87dc9c290a424dea \ | ||
10 | file://pppd/plugins/passprompt.c;beginline=1;endline=10;md5=3bcbcdbf0e369c9a3e0b8c8275b065d8 \ | ||
11 | file://pppd/tdb.c;beginline=1;endline=27;md5=4ca3a9991b011038d085d6675ae7c4e6 \ | ||
12 | file://chat/chat.c;beginline=1;endline=15;md5=0d374b8545ee5c62d7aff1acbd38add2" | ||
13 | |||
14 | SRC_URI = "https://download.samba.org/pub/${BPN}/${BP}.tar.gz \ | ||
15 | file://pon \ | ||
16 | file://poff \ | ||
17 | file://init \ | ||
18 | file://ip-up \ | ||
19 | file://ip-down \ | ||
20 | file://08setupdns \ | ||
21 | file://92removedns \ | ||
22 | file://pap \ | ||
23 | file://ppp_on_boot \ | ||
24 | file://provider \ | ||
25 | file://ppp@.service \ | ||
26 | " | ||
27 | |||
28 | SRC_URI[sha256sum] = "f938b35eccde533ea800b15a7445b2f1137da7f88e32a16898d02dee8adc058d" | ||
29 | |||
30 | inherit autotools-brokensep systemd | ||
31 | |||
32 | TARGET_CC_ARCH += " ${LDFLAGS}" | ||
33 | EXTRA_OEMAKE = "CC='${CC}' STRIPPROG=${STRIP} MANDIR=${D}${datadir}/man/man8 INCDIR=${D}${includedir} LIBDIR=${D}${libdir}/pppd/${PV} BINDIR=${D}${sbindir}" | ||
34 | EXTRA_OECONF = "--disable-strip" | ||
35 | |||
36 | # Package Makefile computes CFLAGS, referencing COPTS. | ||
37 | # Typically hard-coded to '-O2 -g' in the Makefile's. | ||
38 | # | ||
39 | EXTRA_OEMAKE += ' COPTS="${CFLAGS} -I${STAGING_INCDIR}/openssl -I${S}/include"' | ||
40 | |||
41 | do_configure () { | ||
42 | oe_runconf | ||
43 | } | ||
44 | |||
45 | do_install_append () { | ||
46 | make install-etcppp ETCDIR=${D}/${sysconfdir}/ppp | ||
47 | mkdir -p ${D}${bindir}/ ${D}${sysconfdir}/init.d | ||
48 | mkdir -p ${D}${sysconfdir}/ppp/ip-up.d/ | ||
49 | mkdir -p ${D}${sysconfdir}/ppp/ip-down.d/ | ||
50 | install -m 0755 ${WORKDIR}/pon ${D}${bindir}/pon | ||
51 | install -m 0755 ${WORKDIR}/poff ${D}${bindir}/poff | ||
52 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ppp | ||
53 | install -m 0755 ${WORKDIR}/ip-up ${D}${sysconfdir}/ppp/ | ||
54 | install -m 0755 ${WORKDIR}/ip-down ${D}${sysconfdir}/ppp/ | ||
55 | install -m 0755 ${WORKDIR}/08setupdns ${D}${sysconfdir}/ppp/ip-up.d/ | ||
56 | install -m 0755 ${WORKDIR}/92removedns ${D}${sysconfdir}/ppp/ip-down.d/ | ||
57 | mkdir -p ${D}${sysconfdir}/chatscripts | ||
58 | mkdir -p ${D}${sysconfdir}/ppp/peers | ||
59 | install -m 0755 ${WORKDIR}/pap ${D}${sysconfdir}/chatscripts | ||
60 | install -m 0755 ${WORKDIR}/ppp_on_boot ${D}${sysconfdir}/ppp/ppp_on_boot | ||
61 | install -m 0755 ${WORKDIR}/provider ${D}${sysconfdir}/ppp/peers/provider | ||
62 | install -d ${D}${systemd_unitdir}/system | ||
63 | install -m 0644 ${WORKDIR}/ppp@.service ${D}${systemd_unitdir}/system | ||
64 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ | ||
65 | ${D}${systemd_unitdir}/system/ppp@.service | ||
66 | rm -rf ${D}/${mandir}/man8/man8 | ||
67 | chmod u+s ${D}${sbindir}/pppd | ||
68 | } | ||
69 | |||
70 | do_install_append_libc-musl () { | ||
71 | install -Dm 0644 ${S}/include/net/ppp_defs.h ${D}${includedir}/net/ppp_defs.h | ||
72 | } | ||
73 | |||
74 | CONFFILES_${PN} = "${sysconfdir}/ppp/pap-secrets ${sysconfdir}/ppp/chap-secrets ${sysconfdir}/ppp/options" | ||
75 | PACKAGES =+ "${PN}-oa ${PN}-oe ${PN}-radius ${PN}-winbind ${PN}-minconn ${PN}-password ${PN}-l2tp ${PN}-tools" | ||
76 | FILES_${PN} = "${sysconfdir} ${bindir} ${sbindir}/chat ${sbindir}/pppd ${systemd_unitdir}/system/ppp@.service" | ||
77 | FILES_${PN}-oa = "${libdir}/pppd/${PV}/pppoatm.so" | ||
78 | FILES_${PN}-oe = "${sbindir}/pppoe-discovery ${libdir}/pppd/${PV}/*pppoe.so" | ||
79 | FILES_${PN}-radius = "${libdir}/pppd/${PV}/radius.so ${libdir}/pppd/${PV}/radattr.so ${libdir}/pppd/${PV}/radrealms.so" | ||
80 | FILES_${PN}-winbind = "${libdir}/pppd/${PV}/winbind.so" | ||
81 | FILES_${PN}-minconn = "${libdir}/pppd/${PV}/minconn.so" | ||
82 | FILES_${PN}-password = "${libdir}/pppd/${PV}/pass*.so" | ||
83 | FILES_${PN}-l2tp = "${libdir}/pppd/${PV}/*l2tp.so" | ||
84 | FILES_${PN}-tools = "${sbindir}/pppstats ${sbindir}/pppdump" | ||
85 | SUMMARY_${PN}-oa = "Plugin for PPP for PPP-over-ATM support" | ||
86 | SUMMARY_${PN}-oe = "Plugin for PPP for PPP-over-Ethernet support" | ||
87 | SUMMARY_${PN}-radius = "Plugin for PPP for RADIUS support" | ||
88 | SUMMARY_${PN}-winbind = "Plugin for PPP to authenticate against Samba or Windows" | ||
89 | SUMMARY_${PN}-minconn = "Plugin for PPP to set a delay before the idle timeout applies" | ||
90 | SUMMARY_${PN}-password = "Plugin for PPP to get passwords via a pipe" | ||
91 | SUMMARY_${PN}-l2tp = "Plugin for PPP for l2tp support" | ||
92 | SUMMARY_${PN}-tools = "Additional tools for the PPP package" | ||
93 | |||
94 | # Ignore compatibility symlink rp-pppoe.so->pppoe.so | ||
95 | INSANE_SKIP_${PN}-oe += "dev-so" | ||