summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb')
-rw-r--r--meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
new file mode 100644
index 0000000000..6861d8ad44
--- /dev/null
+++ b/meta/recipes-connectivity/ppp-dialin/ppp-dialin_0.1.bb
@@ -0,0 +1,35 @@
1SECTION = "console/network"
2DESCRIPTION = "Enables PPP dial-in through a serial connection"
3DEPENDS = "ppp"
4RDEPENDS = "ppp"
5PR = "r5"
6LICENSE = "MIT"
7
8SRC_URI = "file://host-peer \
9 file://ppp-dialin"
10
11do_install() {
12 install -d ${D}${sysconfdir}/ppp/peers
13 install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host
14
15 install -d ${D}${sbindir}
16 install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir}
17}
18
19PACKAGE_ARCH = "all"
20
21pkg_postinst() {
22if test "x$D" != "x"; then
23 exit 1
24else
25 adduser --system --home /dev/null --no-create-home --empty-password --ingroup nogroup -s ${sbindir}/ppp-dialin ppp
26fi
27}
28
29pkg_postrm() {
30if test "x$D" != "x"; then
31 exit 1
32else
33 deluser ppp
34fi
35}