diff options
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2n.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.0.2n.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb new file mode 100644 index 0000000000..32444c6092 --- /dev/null +++ b/meta/recipes-connectivity/openssl/openssl_1.0.2n.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | require openssl10.inc | ||
2 | |||
3 | # For target side versions of openssl enable support for OCF Linux driver | ||
4 | # if they are available. | ||
5 | |||
6 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" | ||
7 | CFLAG_append_class-native = " -fPIC" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=057d9218c6180e1d9ee407572b2dd225" | ||
10 | |||
11 | export DIRS = "crypto ssl apps engines" | ||
12 | export OE_LDFLAGS="${LDFLAGS}" | ||
13 | |||
14 | SRC_URI += "file://find.pl;subdir=openssl-${PV}/util/ \ | ||
15 | file://run-ptest \ | ||
16 | file://openssl-c_rehash.sh \ | ||
17 | file://configure-targets.patch \ | ||
18 | file://shared-libs.patch \ | ||
19 | file://oe-ldflags.patch \ | ||
20 | file://engines-install-in-libdir-ssl.patch \ | ||
21 | file://debian1.0.2/block_diginotar.patch \ | ||
22 | file://debian1.0.2/block_digicert_malaysia.patch \ | ||
23 | file://debian/ca.patch \ | ||
24 | file://debian/c_rehash-compat.patch \ | ||
25 | file://debian/debian-targets.patch \ | ||
26 | file://debian/man-dir.patch \ | ||
27 | file://debian/man-section.patch \ | ||
28 | file://debian/no-rpath.patch \ | ||
29 | file://debian/no-symbolic.patch \ | ||
30 | file://debian/pic.patch \ | ||
31 | file://debian1.0.2/version-script.patch \ | ||
32 | file://debian1.0.2/soname.patch \ | ||
33 | file://openssl_fix_for_x32.patch \ | ||
34 | file://openssl-fix-des.pod-error.patch \ | ||
35 | file://Makefiles-ptest.patch \ | ||
36 | file://ptest-deps.patch \ | ||
37 | file://openssl-1.0.2a-x32-asm.patch \ | ||
38 | file://ptest_makefile_deps.patch \ | ||
39 | file://configure-musl-target.patch \ | ||
40 | file://parallel.patch \ | ||
41 | file://openssl-util-perlpath.pl-cwd.patch \ | ||
42 | file://Use-SHA256-not-MD5-as-default-digest.patch \ | ||
43 | file://0001-Fix-build-with-clang-using-external-assembler.patch \ | ||
44 | file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \ | ||
45 | " | ||
46 | SRC_URI[md5sum] = "13bdc1b1d1ff39b6fd42a255e74676a4" | ||
47 | SRC_URI[sha256sum] = "370babb75f278c39e0c50e8c4e7493bc0f18db6867478341a832a982fd15a8fe" | ||
48 | |||
49 | PACKAGES =+ "${PN}-engines" | ||
50 | FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" | ||
51 | |||
52 | # The crypto_use_bigint patch means that perl's bignum module needs to be | ||
53 | # installed, but some distributions (for example Fedora 23) don't ship it by | ||
54 | # default. As the resulting error is very misleading check for bignum before | ||
55 | # building. | ||
56 | do_configure_prepend() { | ||
57 | if ! perl -Mbigint -e true; then | ||
58 | bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake." | ||
59 | fi | ||
60 | } | ||