summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2k.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2k.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2k.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2k.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2k.bb
new file mode 100644
index 0000000000..922819b3d5
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2k.bb
@@ -0,0 +1,60 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8CFLAG_append_class-native = " -fPIC"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
11
12export DIRS = "crypto ssl apps engines"
13export OE_LDFLAGS="${LDFLAGS}"
14
15SRC_URI += "file://find.pl;subdir=${BP}/util/ \
16 file://run-ptest \
17 file://openssl-c_rehash.sh \
18 file://configure-targets.patch \
19 file://shared-libs.patch \
20 file://oe-ldflags.patch \
21 file://engines-install-in-libdir-ssl.patch \
22 file://debian1.0.2/block_diginotar.patch \
23 file://debian1.0.2/block_digicert_malaysia.patch \
24 file://debian/ca.patch \
25 file://debian/c_rehash-compat.patch \
26 file://debian/debian-targets.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-rpath.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/pic.patch \
32 file://debian1.0.2/version-script.patch \
33 file://openssl_fix_for_x32.patch \
34 file://fix-cipher-des-ede3-cfb1.patch \
35 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
36 file://openssl-fix-des.pod-error.patch \
37 file://Makefiles-ptest.patch \
38 file://ptest-deps.patch \
39 file://openssl-1.0.2a-x32-asm.patch \
40 file://ptest_makefile_deps.patch \
41 file://configure-musl-target.patch \
42 file://parallel.patch \
43 file://openssl-util-perlpath.pl-cwd.patch \
44 file://Use-SHA256-not-MD5-as-default-digest.patch \
45 "
46SRC_URI[md5sum] = "f965fc0bf01bf882b31314b61391ae65"
47SRC_URI[sha256sum] = "6b3977c61f2aedf0f96367dcfb5c6e578cf37e7b8d913b4ecb6643c3cb88d8c0"
48
49PACKAGES =+ "${PN}-engines"
50FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
51
52# The crypto_use_bigint patch means that perl's bignum module needs to be
53# installed, but some distributions (for example Fedora 23) don't ship it by
54# default. As the resulting error is very misleading check for bignum before
55# building.
56do_configure_prepend() {
57 if ! perl -Mbigint -e true; then
58 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
59 fi
60}