summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2j.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2j.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb
new file mode 100644
index 0000000000..257e3cfc4b
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2j.bb
@@ -0,0 +1,58 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://find.pl;subdir=${BP}/util/ \
15 file://run-ptest \
16 file://openssl-c_rehash.sh \
17 file://configure-targets.patch \
18 file://shared-libs.patch \
19 file://oe-ldflags.patch \
20 file://engines-install-in-libdir-ssl.patch \
21 file://debian1.0.2/block_diginotar.patch \
22 file://debian1.0.2/block_digicert_malaysia.patch \
23 file://debian/ca.patch \
24 file://debian/c_rehash-compat.patch \
25 file://debian/debian-targets.patch \
26 file://debian/man-dir.patch \
27 file://debian/man-section.patch \
28 file://debian/no-rpath.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/pic.patch \
31 file://debian1.0.2/version-script.patch \
32 file://openssl_fix_for_x32.patch \
33 file://fix-cipher-des-ede3-cfb1.patch \
34 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
35 file://openssl-fix-des.pod-error.patch \
36 file://Makefiles-ptest.patch \
37 file://ptest-deps.patch \
38 file://openssl-1.0.2a-x32-asm.patch \
39 file://ptest_makefile_deps.patch \
40 file://configure-musl-target.patch \
41 file://parallel.patch \
42 file://openssl-util-perlpath.pl-cwd.patch \
43 "
44SRC_URI[md5sum] = "96322138f0b69e61b7212bc53d5e912b"
45SRC_URI[sha256sum] = "e7aff292be21c259c6af26469c7a9b3ba26e9abaaffd325e3dccc9785256c431"
46
47PACKAGES =+ "${PN}-engines"
48FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
49
50# The crypto_use_bigint patch means that perl's bignum module needs to be
51# installed, but some distributions (for example Fedora 23) don't ship it by
52# default. As the resulting error is very misleading check for bignum before
53# building.
54do_configure_prepend() {
55 if ! perl -Mbigint -e true; then
56 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
57 fi
58}