summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2i.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2i.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2i.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2i.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2i.bb
new file mode 100644
index 0000000000..c32f47296c
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2i.bb
@@ -0,0 +1,59 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://find.pl;subdir=${BP}/util/ \
15 file://run-ptest \
16 file://openssl-c_rehash.sh \
17 file://configure-targets.patch \
18 file://shared-libs.patch \
19 file://oe-ldflags.patch \
20 file://engines-install-in-libdir-ssl.patch \
21 file://debian1.0.2/block_diginotar.patch \
22 file://debian1.0.2/block_digicert_malaysia.patch \
23 file://debian/ca.patch \
24 file://debian/c_rehash-compat.patch \
25 file://debian/debian-targets.patch \
26 file://debian/man-dir.patch \
27 file://debian/man-section.patch \
28 file://debian/no-rpath.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/pic.patch \
31 file://debian1.0.2/version-script.patch \
32 file://openssl_fix_for_x32.patch \
33 file://fix-cipher-des-ede3-cfb1.patch \
34 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
35 file://openssl-fix-des.pod-error.patch \
36 file://Makefiles-ptest.patch \
37 file://ptest-deps.patch \
38 file://openssl-1.0.2a-x32-asm.patch \
39 file://ptest_makefile_deps.patch \
40 file://configure-musl-target.patch \
41 file://parallel.patch \
42 file://openssl-util-perlpath.pl-cwd.patch \
43 file://Fix-typo-introduced-by-a03f81f4.patch \
44 "
45SRC_URI[md5sum] = "678374e63f8df456a697d3e5e5a931fb"
46SRC_URI[sha256sum] = "9287487d11c9545b6efb287cdb70535d4e9b284dd10d51441d9b9963d000de6f"
47
48PACKAGES =+ "${PN}-engines"
49FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
50
51# The crypto_use_bigint patch means that perl's bignum module needs to be
52# installed, but some distributions (for example Fedora 23) don't ship it by
53# default. As the resulting error is very misleading check for bignum before
54# building.
55do_configure_prepend() {
56 if ! perl -Mbigint -e true; then
57 bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake."
58 fi
59}