diff options
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2h.bb')
-rw-r--r-- | meta/recipes-connectivity/openssl/openssl_1.0.2h.bb | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb new file mode 100644 index 0000000000..ae65992b4e --- /dev/null +++ b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | require openssl.inc | ||
2 | |||
3 | # For target side versions of openssl enable support for OCF Linux driver | ||
4 | # if they are available. | ||
5 | DEPENDS += "cryptodev-linux" | ||
6 | |||
7 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6" | ||
10 | |||
11 | export DIRS = "crypto ssl apps engines" | ||
12 | export OE_LDFLAGS="${LDFLAGS}" | ||
13 | |||
14 | SRC_URI += "file://find.pl;subdir=${BP}/util/ \ | ||
15 | file://run-ptest \ | ||
16 | file://configure-targets.patch \ | ||
17 | file://shared-libs.patch \ | ||
18 | file://oe-ldflags.patch \ | ||
19 | file://engines-install-in-libdir-ssl.patch \ | ||
20 | file://debian1.0.2/block_diginotar.patch \ | ||
21 | file://debian1.0.2/block_digicert_malaysia.patch \ | ||
22 | file://debian/ca.patch \ | ||
23 | file://debian/c_rehash-compat.patch \ | ||
24 | file://debian/debian-targets.patch \ | ||
25 | file://debian/man-dir.patch \ | ||
26 | file://debian/man-section.patch \ | ||
27 | file://debian/no-rpath.patch \ | ||
28 | file://debian/no-symbolic.patch \ | ||
29 | file://debian/pic.patch \ | ||
30 | file://debian1.0.2/version-script.patch \ | ||
31 | file://openssl_fix_for_x32.patch \ | ||
32 | file://fix-cipher-des-ede3-cfb1.patch \ | ||
33 | file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \ | ||
34 | file://openssl-fix-des.pod-error.patch \ | ||
35 | file://Makefiles-ptest.patch \ | ||
36 | file://ptest-deps.patch \ | ||
37 | file://openssl-1.0.2a-x32-asm.patch \ | ||
38 | file://ptest_makefile_deps.patch \ | ||
39 | file://configure-musl-target.patch \ | ||
40 | file://parallel.patch \ | ||
41 | " | ||
42 | SRC_URI[md5sum] = "9392e65072ce4b614c1392eefc1f23d0" | ||
43 | SRC_URI[sha256sum] = "1d4007e53aad94a5b2002fe045ee7bb0b3d98f1a47f8b2bc851dcd1c74332919" | ||
44 | |||
45 | PACKAGES =+ "${PN}-engines" | ||
46 | FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" | ||
47 | |||
48 | # The crypto_use_bigint patch means that perl's bignum module needs to be | ||
49 | # installed, but some distributions (for example Fedora 23) don't ship it by | ||
50 | # default. As the resulting error is very misleading check for bignum before | ||
51 | # building. | ||
52 | do_configure_prepend() { | ||
53 | if ! perl -Mbigint -e true; then | ||
54 | bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake." | ||
55 | fi | ||
56 | } | ||