summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2h.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2h.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
new file mode 100644
index 0000000000..9c35099b16
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
@@ -0,0 +1,56 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://debian1.0.2/block_diginotar.patch \
19 file://debian1.0.2/block_digicert_malaysia.patch \
20 file://debian/ca.patch \
21 file://debian/c_rehash-compat.patch \
22 file://debian/debian-targets.patch \
23 file://debian/man-dir.patch \
24 file://debian/man-section.patch \
25 file://debian/no-rpath.patch \
26 file://debian/no-symbolic.patch \
27 file://debian/pic.patch \
28 file://debian1.0.2/version-script.patch \
29 file://openssl_fix_for_x32.patch \
30 file://fix-cipher-des-ede3-cfb1.patch \
31 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
32 file://find.pl \
33 file://openssl-fix-des.pod-error.patch \
34 file://Makefiles-ptest.patch \
35 file://ptest-deps.patch \
36 file://run-ptest \
37 file://crypto_use_bigint_in_x86-64_perl.patch \
38 "
39
40SRC_URI[md5sum] = "9392e65072ce4b614c1392eefc1f23d0"
41SRC_URI[sha256sum] = "1d4007e53aad94a5b2002fe045ee7bb0b3d98f1a47f8b2bc851dcd1c74332919"
42
43PACKAGES =+ " \
44 ${PN}-engines \
45 ${PN}-engines-dbg \
46 "
47
48FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
49FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
50
51PARALLEL_MAKE = ""
52PARALLEL_MAKEINST = ""
53
54do_configure_prepend() {
55 cp ${WORKDIR}/find.pl ${S}/util/find.pl
56}