summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.1t.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.1t.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1t.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1t.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1t.bb
new file mode 100644
index 0000000000..1737730065
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.1t.bb
@@ -0,0 +1,55 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "cryptodev-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=27ffa5d74bb5a337056c14b2ef93fbf6"
10
11export DIRS = "crypto ssl apps engines"
12export OE_LDFLAGS="${LDFLAGS}"
13
14SRC_URI += "file://configure-targets.patch \
15 file://shared-libs.patch \
16 file://oe-ldflags.patch \
17 file://engines-install-in-libdir-ssl.patch \
18 file://debian/version-script.patch \
19 file://debian/pic.patch \
20 file://debian/c_rehash-compat.patch \
21 file://debian/ca.patch \
22 file://debian/make-targets.patch \
23 file://debian/no-rpath.patch \
24 file://debian/man-dir.patch \
25 file://debian/man-section.patch \
26 file://debian/no-symbolic.patch \
27 file://debian/debian-targets.patch \
28 file://openssl_fix_for_x32.patch \
29 file://fix-cipher-des-ede3-cfb1.patch \
30 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
31 file://initial-aarch64-bits.patch \
32 file://find.pl \
33 file://openssl-fix-des.pod-error.patch \
34 file://Makefiles-ptest.patch \
35 file://ptest-deps.patch \
36 file://run-ptest \
37 "
38
39SRC_URI[md5sum] = "9837746fcf8a6727d46d22ca35953da1"
40SRC_URI[sha256sum] = "4a6ee491a2fdb22e519c76fdc2a628bb3cec12762cd456861d207996c8a07088"
41
42PACKAGES =+ " \
43 ${PN}-engines \
44 ${PN}-engines-dbg \
45 "
46
47FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
48FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
49
50PARALLEL_MAKE = ""
51PARALLEL_MAKEINST = ""
52
53do_configure_prepend() {
54 cp ${WORKDIR}/find.pl ${S}/util/find.pl
55}