summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.1e.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1e.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
new file mode 100644
index 0000000000..4134ae21e6
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
@@ -0,0 +1,57 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "ocf-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9PR = "${INC_PR}.0"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
12
13export DIRS = "crypto ssl apps engines"
14export OE_LDFLAGS="${LDFLAGS}"
15
16SRC_URI += "file://configure-targets.patch \
17 file://shared-libs.patch \
18 file://oe-ldflags.patch \
19 file://engines-install-in-libdir-ssl.patch \
20 file://openssl-fix-link.patch \
21 file://debian/version-script.patch \
22 file://debian/pic.patch \
23 file://debian/c_rehash-compat.patch \
24 file://debian/ca.patch \
25 file://debian/make-targets.patch \
26 file://debian/no-rpath.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/debian-targets.patch \
31 file://openssl_fix_for_x32.patch \
32 file://Makefiles-ptest.patch \
33 file://openssl-fix-doc.patch \
34 file://fix-cipher-des-ede3-cfb1.patch \
35 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
36 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
37 file://find.pl \
38 file://run-ptest \
39 "
40
41SRC_URI[md5sum] = "66bf6f10f060d561929de96f9dfe5b8c"
42SRC_URI[sha256sum] = "f74f15e8c8ff11aa3d5bb5f276d202ec18d7246e95f961db76054199c69c1ae3"
43
44PACKAGES =+ " \
45 ${PN}-engines \
46 ${PN}-engines-dbg \
47 "
48
49FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
50FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
51
52PARALLEL_MAKE = ""
53PARALLEL_MAKEINST = ""
54
55do_configure_prepend() {
56 cp ${WORKDIR}/find.pl ${S}/util/find.pl
57}