summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.0h.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.0h.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.0h.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0h.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0h.bb
new file mode 100644
index 0000000000..744fe2a6b7
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.0h.bb
@@ -0,0 +1,45 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "ocf-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9PR = "${INC_PR}.1"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
12
13export DIRS = "crypto ssl apps engines"
14export OE_LDFLAGS="${LDFLAGS}"
15
16SRC_URI += "file://configure-targets.patch \
17 file://shared-libs.patch \
18 file://oe-ldflags.patch \
19 file://engines-install-in-libdir-ssl.patch \
20 file://openssl-fix-link.patch \
21 file://debian/version-script.patch \
22 file://debian/pic.patch \
23 file://debian/c_rehash-compat.patch \
24 file://debian/ca.patch \
25 file://debian/make-targets.patch \
26 file://debian/no-rpath.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/no-symbolic.patch \
30 file://debian/debian-targets.patch \
31 file://openssl_fix_for_x32.patch \
32 "
33
34SRC_URI[md5sum] = "a5bc483c570f2ac3758ce5c19b667fab"
35SRC_URI[sha256sum] = "7e3dfc21aa57ed33ea673170053d1921322803b8a6a624a4f0d2e4c308bd418d"
36
37PACKAGES =+ " \
38 ${PN}-engines \
39 ${PN}-engines-dbg \
40 "
41
42FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
43FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
44
45PARALLEL_MAKEINST = ""