summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.0f.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.0f.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb b/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
new file mode 100644
index 0000000000..f3404d6084
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.0f.bb
@@ -0,0 +1,46 @@
1require openssl.inc
2
3# For target side versions of openssl enable support for OCF Linux driver
4# if they are available.
5DEPENDS += "ocf-linux"
6
7CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
8
9PR = "${INC_PR}.0"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=f9a8f968107345e0b75aa8c2ecaa7ec8"
12
13export DIRS = "crypto ssl apps engines"
14export OE_LDFLAGS="${LDFLAGS}"
15
16SRC_URI += "file://configure-targets.patch \
17 file://shared-libs.patch \
18 file://oe-ldflags.patch \
19 file://engines-install-in-libdir-ssl.patch \
20 file://openssl-fix-link.patch \
21 file://debian/version-script.patch \
22 file://debian/pic.patch \
23 file://debian/c_rehash-compat.patch \
24 file://debian/ca.patch \
25 file://debian/make-targets.patch \
26 file://debian/no-rpath.patch \
27 file://debian/man-dir.patch \
28 file://debian/man-section.patch \
29 file://debian/pkg-config.patch \
30 file://debian/no-symbolic.patch \
31 file://debian/debian-targets.patch \
32 file://openssl_fix_for_x32.patch \
33 "
34
35SRC_URI[md5sum] = "e358705fb4a8827b5e9224a73f442025"
36SRC_URI[sha256sum] = "faf1eab0ef85fd6c3beca271c356b31b5cc831e2c6b7f23cf672e7ab4680fde1"
37
38PACKAGES =+ " \
39 ${PN}-engines \
40 ${PN}-engines-dbg \
41 "
42
43FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines"
44FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"
45
46PARALLEL_MAKEINST = ""