summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff')
-rw-r--r--meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff762
1 files changed, 762 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff b/meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff
new file mode 100644
index 0000000000..ced45a338d
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-0.9.8s/debian/perl-path.diff
@@ -0,0 +1,762 @@
1Upstream-Status: Backport [debian]
2
3From: Kurt Roeckx <kurt@roeckx.be>
4Subject: Change the perl path's to /usr/bin/perl
5
6This is the result of running:
7perl util/perlpath.pl /usr/bin
8
9The upstream sources have this set to various different paths.
10
11--- openssl-0.9.8m.orig/Configure
12+++ openssl-0.9.8m/Configure
13@@ -1,4 +1,4 @@
14-:
15+#!/usr/bin/perl
16 eval 'exec perl -S $0 ${1+"$@"}'
17 if $running_under_some_shell;
18 ##
19--- openssl-0.9.8m.orig/VMS/VMSify-conf.pl
20+++ openssl-0.9.8m/VMS/VMSify-conf.pl
21@@ -1,4 +1,4 @@
22-#! /usr/bin/perl
23+#!/usr/bin/perl
24
25 use strict;
26 use warnings;
27--- openssl-0.9.8m.orig/Netware/do_tests.pl
28+++ openssl-0.9.8m/Netware/do_tests.pl
29@@ -1,4 +1,4 @@
30-# perl script to run OpenSSL tests
31+#!/usr/bin/perl
32
33
34 my $base_path = "\\openssl";
35--- openssl-0.9.8m.orig/apps/progs.pl
36+++ openssl-0.9.8m/apps/progs.pl
37@@ -1,4 +1,4 @@
38-#!/usr/local/bin/perl
39+#!/usr/bin/perl
40
41 print "/* apps/progs.h */\n";
42 print "/* automatically generated by progs.pl for openssl.c */\n\n";
43--- openssl-0.9.8m.orig/os2/backwardify.pl
44+++ openssl-0.9.8m/os2/backwardify.pl
45@@ -1,4 +1,4 @@
46-#!/usr/bin/perl -w
47+#!/usr/bin/perl
48 use strict;
49
50 # Use as $0
51--- openssl-0.9.8m.orig/times/091/mips-rel.pl
52+++ openssl-0.9.8m/times/091/mips-rel.pl
53@@ -1,4 +1,4 @@
54-#!/usr/local/bin/perl
55+#!/usr/bin/perl
56
57 &doit(100,"Pentium 100 32",0.0195,0.1000,0.6406,4.6100); # pentium-100
58 &doit(200,"PPro 200 32",0.0070,0.0340,0.2087,1.4700); # pentium-100
59--- openssl-0.9.8m.orig/fips/mkfipsscr.pl
60+++ openssl-0.9.8m/fips/mkfipsscr.pl
61@@ -1,4 +1,4 @@
62-#!/usr/local/bin/perl -w
63+#!/usr/bin/perl
64 # Quick & dirty utility to generate a script for executing the
65 # FIPS 140-2 CMVP algorithm tests based on the pathnames of
66 # input algorithm test files actually present (the unqualified
67--- openssl-0.9.8m.orig/fips/fipsalgtest.pl
68+++ openssl-0.9.8m/fips/fipsalgtest.pl
69@@ -1,4 +1,4 @@
70-#!/usr/bin/perl -w
71+#!/usr/bin/perl
72 # Perl utility to run or verify FIPS 140-2 CMVP algorithm tests based on the
73 # pathnames of input algorithm test files actually present (the unqualified
74 # file names are consistent but the pathnames are not).
75--- openssl-0.9.8m.orig/ms/uplink.pl
76+++ openssl-0.9.8m/ms/uplink.pl
77@@ -1,4 +1,4 @@
78-#!/usr/bin/env perl
79+#!/usr/bin/perl
80 #
81 # For Microsoft CL this is implemented as inline assembler. So that
82 # even though this script can generate even Win32 code, we'll be
83--- openssl-0.9.8m.orig/ms/segrenam.pl
84+++ openssl-0.9.8m/ms/segrenam.pl
85@@ -1,4 +1,4 @@
86-#!/usr/bin/env perl
87+#!/usr/bin/perl
88
89 my $quiet = 1;
90
91--- openssl-0.9.8m.orig/ms/cmp.pl
92+++ openssl-0.9.8m/ms/cmp.pl
93@@ -1,4 +1,4 @@
94-#!/usr/local/bin/perl
95+#!/usr/bin/perl
96
97 ($#ARGV == 1) || die "usage: cmp.pl <file1> <file2>\n";
98
99--- openssl-0.9.8m.orig/test/cms-test.pl
100+++ openssl-0.9.8m/test/cms-test.pl
101@@ -1,4 +1,4 @@
102-# test/cms-test.pl
103+#!/usr/bin/perl
104 # Written by Dr Stephen N Henson (steve@openssl.org) for the OpenSSL
105 # project.
106 #
107--- openssl-0.9.8m.orig/test/cms-examples.pl
108+++ openssl-0.9.8m/test/cms-examples.pl
109@@ -1,4 +1,4 @@
110-# test/cms-examples.pl
111+#!/usr/bin/perl
112 # Written by Dr Stephen N Henson (steve@openssl.org) for the OpenSSL
113 # project.
114 #
115--- openssl-0.9.8m.orig/demos/b64.pl
116+++ openssl-0.9.8m/demos/b64.pl
117@@ -1,4 +1,4 @@
118-#!/usr/local/bin/perl
119+#!/usr/bin/perl
120
121 #
122 # Make PEM encoded data have lines of 64 bytes of data
123--- openssl-0.9.8m.orig/demos/tunala/configure.in
124+++ openssl-0.9.8m/demos/tunala/configure.in
125@@ -1,4 +1,4 @@
126-dnl Process this file with autoconf to produce a configure script.
127+#!/usr/bin/perl
128 AC_INIT(tunala.c)
129 AM_CONFIG_HEADER(config.h)
130 AM_INIT_AUTOMAKE(tunala, 0.0.1-dev)
131--- openssl-0.9.8m.orig/crypto/x86cpuid.pl
132+++ openssl-0.9.8m/crypto/x86cpuid.pl
133@@ -1,4 +1,4 @@
134-#!/usr/bin/env perl
135+#!/usr/bin/perl
136
137 push(@INC,"perlasm");
138 require "x86asm.pl";
139--- openssl-0.9.8m.orig/crypto/x86_64cpuid.pl
140+++ openssl-0.9.8m/crypto/x86_64cpuid.pl
141@@ -1,4 +1,4 @@
142-#!/usr/bin/env perl
143+#!/usr/bin/perl
144
145 $output=shift;
146 $masm=1 if ($output =~ /\.asm/);
147--- openssl-0.9.8m.orig/crypto/md5/asm/md5-586.pl
148+++ openssl-0.9.8m/crypto/md5/asm/md5-586.pl
149@@ -1,4 +1,4 @@
150-#!/usr/local/bin/perl
151+#!/usr/bin/perl
152
153 # Normal is the
154 # md5_block_x86(MD5_CTX *c, ULONG *X);
155--- openssl-0.9.8m.orig/crypto/md5/asm/md5-x86_64.pl
156+++ openssl-0.9.8m/crypto/md5/asm/md5-x86_64.pl
157@@ -1,4 +1,4 @@
158-#!/usr/bin/perl -w
159+#!/usr/bin/perl
160 #
161 # MD5 optimized for AMD64.
162 #
163--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-ia64.pl
164+++ openssl-0.9.8m/crypto/sha/asm/sha1-ia64.pl
165@@ -1,4 +1,4 @@
166-#!/usr/bin/env perl
167+#!/usr/bin/perl
168 #
169 # ====================================================================
170 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
171--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-x86_64.pl
172+++ openssl-0.9.8m/crypto/sha/asm/sha1-x86_64.pl
173@@ -1,4 +1,4 @@
174-#!/usr/bin/env perl
175+#!/usr/bin/perl
176 #
177 # ====================================================================
178 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
179--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-sse2.pl
180+++ openssl-0.9.8m/crypto/sha/asm/sha512-sse2.pl
181@@ -1,4 +1,4 @@
182-#!/usr/bin/env perl
183+#!/usr/bin/perl
184 #
185 # ====================================================================
186 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
187--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-ia64.pl
188+++ openssl-0.9.8m/crypto/sha/asm/sha512-ia64.pl
189@@ -1,4 +1,4 @@
190-#!/usr/bin/env perl
191+#!/usr/bin/perl
192 #
193 # ====================================================================
194 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
195--- openssl-0.9.8m.orig/crypto/sha/asm/sha512-x86_64.pl
196+++ openssl-0.9.8m/crypto/sha/asm/sha512-x86_64.pl
197@@ -1,4 +1,4 @@
198-#!/usr/bin/env perl
199+#!/usr/bin/perl
200 #
201 # ====================================================================
202 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
203--- openssl-0.9.8m.orig/crypto/sha/asm/sha1-586.pl
204+++ openssl-0.9.8m/crypto/sha/asm/sha1-586.pl
205@@ -1,4 +1,4 @@
206-#!/usr/bin/env perl
207+#!/usr/bin/perl
208
209 # ====================================================================
210 # [Re]written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
211--- openssl-0.9.8m.orig/crypto/des/asm/des-586.pl
212+++ openssl-0.9.8m/crypto/des/asm/des-586.pl
213@@ -1,4 +1,4 @@
214-#!/usr/local/bin/perl
215+#!/usr/bin/perl
216 #
217 # The inner loop instruction sequence and the IP/FP modifications are from
218 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
219--- openssl-0.9.8m.orig/crypto/des/asm/desboth.pl
220+++ openssl-0.9.8m/crypto/des/asm/desboth.pl
221@@ -1,4 +1,4 @@
222-#!/usr/local/bin/perl
223+#!/usr/bin/perl
224
225 $L="edi";
226 $R="esi";
227--- openssl-0.9.8m.orig/crypto/des/asm/des686.pl
228+++ openssl-0.9.8m/crypto/des/asm/des686.pl
229@@ -1,4 +1,4 @@
230-#!/usr/local/bin/perl
231+#!/usr/bin/perl
232
233 $prog="des686.pl";
234
235--- openssl-0.9.8m.orig/crypto/des/asm/crypt586.pl
236+++ openssl-0.9.8m/crypto/des/asm/crypt586.pl
237@@ -1,4 +1,4 @@
238-#!/usr/local/bin/perl
239+#!/usr/bin/perl
240 #
241 # The inner loop instruction sequence and the IP/FP modifications are from
242 # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
243--- openssl-0.9.8m.orig/crypto/lhash/num.pl
244+++ openssl-0.9.8m/crypto/lhash/num.pl
245@@ -1,4 +1,4 @@
246-#!/usr/local/bin/perl
247+#!/usr/bin/perl
248
249 #node 10 -> 4
250
251--- openssl-0.9.8m.orig/crypto/ripemd/asm/rmd-586.pl
252+++ openssl-0.9.8m/crypto/ripemd/asm/rmd-586.pl
253@@ -1,4 +1,4 @@
254-#!/usr/local/bin/perl
255+#!/usr/bin/perl
256
257 # Normal is the
258 # ripemd160_block_asm_data_order(RIPEMD160_CTX *c, ULONG *X,int blocks);
259--- openssl-0.9.8m.orig/crypto/rc4/asm/rc4-586.pl
260+++ openssl-0.9.8m/crypto/rc4/asm/rc4-586.pl
261@@ -1,4 +1,4 @@
262-#!/usr/local/bin/perl
263+#!/usr/bin/perl
264
265 # At some point it became apparent that the original SSLeay RC4
266 # assembler implementation performs suboptimaly on latest IA-32
267--- openssl-0.9.8m.orig/crypto/rc4/asm/rc4-x86_64.pl
268+++ openssl-0.9.8m/crypto/rc4/asm/rc4-x86_64.pl
269@@ -1,4 +1,4 @@
270-#!/usr/bin/env perl
271+#!/usr/bin/perl
272 #
273 # ====================================================================
274 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
275--- openssl-0.9.8m.orig/crypto/cast/asm/cast-586.pl
276+++ openssl-0.9.8m/crypto/cast/asm/cast-586.pl
277@@ -1,4 +1,4 @@
278-#!/usr/local/bin/perl
279+#!/usr/bin/perl
280
281 # define for pentium pro friendly version
282 $ppro=1;
283--- openssl-0.9.8m.orig/crypto/rc5/asm/rc5-586.pl
284+++ openssl-0.9.8m/crypto/rc5/asm/rc5-586.pl
285@@ -1,4 +1,4 @@
286-#!/usr/local/bin/perl
287+#!/usr/bin/perl
288
289 push(@INC,"perlasm","../../perlasm");
290 require "x86asm.pl";
291--- openssl-0.9.8m.orig/crypto/perlasm/x86ms.pl
292+++ openssl-0.9.8m/crypto/perlasm/x86ms.pl
293@@ -1,4 +1,4 @@
294-#!/usr/local/bin/perl
295+#!/usr/bin/perl
296
297 package x86ms;
298
299--- openssl-0.9.8m.orig/crypto/perlasm/x86asm.pl
300+++ openssl-0.9.8m/crypto/perlasm/x86asm.pl
301@@ -1,4 +1,4 @@
302-#!/usr/local/bin/perl
303+#!/usr/bin/perl
304
305 # require 'x86asm.pl';
306 # &asm_init("cpp","des-586.pl");
307--- openssl-0.9.8m.orig/crypto/perlasm/x86nasm.pl
308+++ openssl-0.9.8m/crypto/perlasm/x86nasm.pl
309@@ -1,4 +1,4 @@
310-#!/usr/local/bin/perl
311+#!/usr/bin/perl
312
313 package x86nasm;
314
315--- openssl-0.9.8m.orig/crypto/perlasm/x86unix.pl
316+++ openssl-0.9.8m/crypto/perlasm/x86unix.pl
317@@ -1,4 +1,4 @@
318-#!/usr/local/bin/perl
319+#!/usr/bin/perl
320
321 package x86unix; # GAS actually...
322
323--- openssl-0.9.8m.orig/crypto/perlasm/cbc.pl
324+++ openssl-0.9.8m/crypto/perlasm/cbc.pl
325@@ -1,4 +1,4 @@
326-#!/usr/local/bin/perl
327+#!/usr/bin/perl
328
329 # void des_ncbc_encrypt(input, output, length, schedule, ivec, enc)
330 # des_cblock (*input);
331--- openssl-0.9.8m.orig/crypto/perlasm/x86_64-xlate.pl
332+++ openssl-0.9.8m/crypto/perlasm/x86_64-xlate.pl
333@@ -1,4 +1,4 @@
334-#!/usr/bin/env perl
335+#!/usr/bin/perl
336
337 # Ascetic x86_64 AT&T to MASM assembler translator by <appro>.
338 #
339--- openssl-0.9.8m.orig/crypto/bf/asm/bf-686.pl
340+++ openssl-0.9.8m/crypto/bf/asm/bf-686.pl
341@@ -1,4 +1,4 @@
342-#!/usr/local/bin/perl
343+#!/usr/bin/perl
344
345 push(@INC,"perlasm","../../perlasm");
346 require "x86asm.pl";
347--- openssl-0.9.8m.orig/crypto/bf/asm/bf-586.pl
348+++ openssl-0.9.8m/crypto/bf/asm/bf-586.pl
349@@ -1,4 +1,4 @@
350-#!/usr/local/bin/perl
351+#!/usr/bin/perl
352
353 push(@INC,"perlasm","../../perlasm");
354 require "x86asm.pl";
355--- openssl-0.9.8m.orig/crypto/objects/objects.pl
356+++ openssl-0.9.8m/crypto/objects/objects.pl
357@@ -1,4 +1,4 @@
358-#!/usr/local/bin/perl
359+#!/usr/bin/perl
360
361 open (NUMIN,"$ARGV[1]") || die "Can't open number file $ARGV[1]";
362 $max_nid=0;
363--- openssl-0.9.8m.orig/crypto/objects/obj_dat.pl
364+++ openssl-0.9.8m/crypto/objects/obj_dat.pl
365@@ -1,4 +1,4 @@
366-#!/usr/local/bin/perl
367+#!/usr/bin/perl
368
369 # fixes bug in floating point emulation on sparc64 when
370 # this script produces off-by-one output on sparc64
371--- openssl-0.9.8m.orig/crypto/conf/keysets.pl
372+++ openssl-0.9.8m/crypto/conf/keysets.pl
373@@ -1,4 +1,4 @@
374-#!/usr/local/bin/perl
375+#!/usr/bin/perl
376
377 $NUMBER=0x01;
378 $UPPER=0x02;
379--- openssl-0.9.8m.orig/crypto/bn/bn_prime.pl
380+++ openssl-0.9.8m/crypto/bn/bn_prime.pl
381@@ -1,4 +1,4 @@
382-#!/usr/local/bin/perl
383+#!/usr/bin/perl
384 # bn_prime.pl
385
386 $num=2048;
387--- openssl-0.9.8m.orig/crypto/bn/asm/x86.pl
388+++ openssl-0.9.8m/crypto/bn/asm/x86.pl
389@@ -1,4 +1,4 @@
390-#!/usr/local/bin/perl
391+#!/usr/bin/perl
392
393 push(@INC,"perlasm","../../perlasm");
394 require "x86asm.pl";
395--- openssl-0.9.8m.orig/crypto/bn/asm/ppc.pl
396+++ openssl-0.9.8m/crypto/bn/asm/ppc.pl
397@@ -1,4 +1,4 @@
398-#!/usr/bin/env perl
399+#!/usr/bin/perl
400 #
401 # Implemented as a Perl wrapper as we want to support several different
402 # architectures with single file. We pick up the target based on the
403--- openssl-0.9.8m.orig/crypto/bn/asm/co-586.pl
404+++ openssl-0.9.8m/crypto/bn/asm/co-586.pl
405@@ -1,4 +1,4 @@
406-#!/usr/local/bin/perl
407+#!/usr/bin/perl
408
409 push(@INC,"perlasm","../../perlasm");
410 require "x86asm.pl";
411--- openssl-0.9.8m.orig/crypto/bn/asm/bn-586.pl
412+++ openssl-0.9.8m/crypto/bn/asm/bn-586.pl
413@@ -1,4 +1,4 @@
414-#!/usr/local/bin/perl
415+#!/usr/bin/perl
416
417 push(@INC,"perlasm","../../perlasm");
418 require "x86asm.pl";
419--- openssl-0.9.8m.orig/crypto/bn/asm/mo-586.pl
420+++ openssl-0.9.8m/crypto/bn/asm/mo-586.pl
421@@ -1,4 +1,4 @@
422-#!/usr/bin/env perl
423+#!/usr/bin/perl
424
425 # This is crypto/bn/asm/x86-mont.pl (with asciz from crypto/perlasm/x86asm.pl)
426 # from OpenSSL 0.9.9-dev
427--- openssl-0.9.8m.orig/crypto/bn/asm/x86_64-mont.pl
428+++ openssl-0.9.8m/crypto/bn/asm/x86_64-mont.pl
429@@ -1,4 +1,4 @@
430-#!/usr/bin/env perl
431+#!/usr/bin/perl
432
433 # ====================================================================
434 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
435--- openssl-0.9.8m.orig/crypto/bn/asm/x86/comba.pl
436+++ openssl-0.9.8m/crypto/bn/asm/x86/comba.pl
437@@ -1,4 +1,4 @@
438-#!/usr/local/bin/perl
439+#!/usr/bin/perl
440 # x86 assember
441
442 sub mul_add_c
443--- openssl-0.9.8m.orig/crypto/bn/asm/x86/add.pl
444+++ openssl-0.9.8m/crypto/bn/asm/x86/add.pl
445@@ -1,4 +1,4 @@
446-#!/usr/local/bin/perl
447+#!/usr/bin/perl
448 # x86 assember
449
450 sub bn_add_words
451--- openssl-0.9.8m.orig/crypto/bn/asm/x86/mul.pl
452+++ openssl-0.9.8m/crypto/bn/asm/x86/mul.pl
453@@ -1,4 +1,4 @@
454-#!/usr/local/bin/perl
455+#!/usr/bin/perl
456 # x86 assember
457
458 sub bn_mul_words
459--- openssl-0.9.8m.orig/crypto/bn/asm/x86/mul_add.pl
460+++ openssl-0.9.8m/crypto/bn/asm/x86/mul_add.pl
461@@ -1,4 +1,4 @@
462-#!/usr/local/bin/perl
463+#!/usr/bin/perl
464 # x86 assember
465
466 sub bn_mul_add_words
467--- openssl-0.9.8m.orig/crypto/bn/asm/x86/sqr.pl
468+++ openssl-0.9.8m/crypto/bn/asm/x86/sqr.pl
469@@ -1,4 +1,4 @@
470-#!/usr/local/bin/perl
471+#!/usr/bin/perl
472 # x86 assember
473
474 sub bn_sqr_words
475--- openssl-0.9.8m.orig/crypto/bn/asm/x86/sub.pl
476+++ openssl-0.9.8m/crypto/bn/asm/x86/sub.pl
477@@ -1,4 +1,4 @@
478-#!/usr/local/bin/perl
479+#!/usr/bin/perl
480 # x86 assember
481
482 sub bn_sub_words
483--- openssl-0.9.8m.orig/crypto/bn/asm/x86/div.pl
484+++ openssl-0.9.8m/crypto/bn/asm/x86/div.pl
485@@ -1,4 +1,4 @@
486-#!/usr/local/bin/perl
487+#!/usr/bin/perl
488 # x86 assember
489
490 sub bn_div_words
491--- openssl-0.9.8m.orig/crypto/aes/asm/aes-586.pl
492+++ openssl-0.9.8m/crypto/aes/asm/aes-586.pl
493@@ -1,4 +1,4 @@
494-#!/usr/bin/env perl
495+#!/usr/bin/perl
496 #
497 # ====================================================================
498 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
499--- openssl-0.9.8m.orig/crypto/aes/asm/aes-x86_64.pl
500+++ openssl-0.9.8m/crypto/aes/asm/aes-x86_64.pl
501@@ -1,4 +1,4 @@
502-#!/usr/bin/env perl
503+#!/usr/bin/perl
504 #
505 # ====================================================================
506 # Written by Andy Polyakov <appro@fy.chalmers.se> for the OpenSSL
507--- openssl-0.9.8m.orig/crypto/asn1/charmap.pl
508+++ openssl-0.9.8m/crypto/asn1/charmap.pl
509@@ -1,4 +1,4 @@
510-#!/usr/local/bin/perl -w
511+#!/usr/bin/perl
512
513 use strict;
514
515--- openssl-0.9.8m.orig/util/mksdef.pl
516+++ openssl-0.9.8m/util/mksdef.pl
517@@ -1,4 +1,4 @@
518-
519+#!/usr/bin/perl
520 # Perl script to split libeay32.def into two distinct DEF files for use in
521 # fipdso mode. It works out symbols in each case by running "link" command and
522 # parsing the output to find the list of missing symbols then splitting
523--- openssl-0.9.8m.orig/util/dirname.pl
524+++ openssl-0.9.8m/util/dirname.pl
525@@ -1,4 +1,4 @@
526-#!/usr/local/bin/perl
527+#!/usr/bin/perl
528
529 if ($#ARGV < 0) {
530 die "dirname.pl: too few arguments\n";
531--- openssl-0.9.8m.orig/util/tab_num.pl
532+++ openssl-0.9.8m/util/tab_num.pl
533@@ -1,4 +1,4 @@
534-#!/usr/local/bin/perl
535+#!/usr/bin/perl
536
537 $num=1;
538 $width=40;
539--- openssl-0.9.8m.orig/util/sp-diff.pl
540+++ openssl-0.9.8m/util/sp-diff.pl
541@@ -1,4 +1,4 @@
542-#!/usr/local/bin/perl
543+#!/usr/bin/perl
544 #
545 # This file takes as input, the files that have been output from
546 # ssleay speed.
547--- openssl-0.9.8m.orig/util/mkerr.pl
548+++ openssl-0.9.8m/util/mkerr.pl
549@@ -1,4 +1,4 @@
550-#!/usr/local/bin/perl -w
551+#!/usr/bin/perl
552
553 my $config = "crypto/err/openssl.ec";
554 my $debug = 0;
555--- openssl-0.9.8m.orig/util/clean-depend.pl
556+++ openssl-0.9.8m/util/clean-depend.pl
557@@ -1,4 +1,4 @@
558-#!/usr/local/bin/perl -w
559+#!/usr/bin/perl
560 # Clean the dependency list in a makefile of standard includes...
561 # Written by Ben Laurie <ben@algroup.co.uk> 19 Jan 1999
562
563--- openssl-0.9.8m.orig/util/add_cr.pl
564+++ openssl-0.9.8m/util/add_cr.pl
565@@ -1,4 +1,4 @@
566-#!/usr/local/bin/perl
567+#!/usr/bin/perl
568 #
569 # This adds a copyright message to a souce code file.
570 # It also gets the file name correct.
571--- openssl-0.9.8m.orig/util/pod2man.pl
572+++ openssl-0.9.8m/util/pod2man.pl
573@@ -1,4 +1,4 @@
574-: #!/usr/bin/perl-5.005
575+#!/usr/bin/perl
576 eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
577 if $running_under_some_shell;
578
579--- openssl-0.9.8m.orig/util/mkstack.pl
580+++ openssl-0.9.8m/util/mkstack.pl
581@@ -1,4 +1,4 @@
582-#!/usr/local/bin/perl -w
583+#!/usr/bin/perl
584
585 # This is a utility that searches out "DECLARE_STACK_OF()"
586 # declarations in .h and .c files, and updates/creates/replaces
587--- openssl-0.9.8m.orig/util/selftest.pl
588+++ openssl-0.9.8m/util/selftest.pl
589@@ -1,4 +1,4 @@
590-#!/usr/local/bin/perl -w
591+#!/usr/bin/perl
592 #
593 # Run the test suite and generate a report
594 #
595--- openssl-0.9.8m.orig/util/ck_errf.pl
596+++ openssl-0.9.8m/util/ck_errf.pl
597@@ -1,4 +1,4 @@
598-#!/usr/local/bin/perl
599+#!/usr/bin/perl
600 #
601 # This is just a quick script to scan for cases where the 'error'
602 # function name in a XXXerr() macro is wrong.
603--- openssl-0.9.8m.orig/util/mklink.pl
604+++ openssl-0.9.8m/util/mklink.pl
605@@ -1,4 +1,4 @@
606-#!/usr/local/bin/perl
607+#!/usr/bin/perl
608
609 # mklink.pl
610
611--- openssl-0.9.8m.orig/util/src-dep.pl
612+++ openssl-0.9.8m/util/src-dep.pl
613@@ -1,4 +1,4 @@
614-#!/usr/local/bin/perl
615+#!/usr/bin/perl
616
617 # we make up an array of
618 # $file{function_name}=filename;
619--- openssl-0.9.8m.orig/util/deleof.pl
620+++ openssl-0.9.8m/util/deleof.pl
621@@ -1,4 +1,4 @@
622-#!/usr/local/bin/perl
623+#!/usr/bin/perl
624
625 while (<>)
626 {
627--- openssl-0.9.8m.orig/util/arx.pl
628+++ openssl-0.9.8m/util/arx.pl
629@@ -1,4 +1,4 @@
630-#!/bin/perl
631+#!/usr/bin/perl
632
633 # Simple perl script to wrap round "ar" program and exclude any
634 # object files in the environment variable EXCL_OBJ
635--- openssl-0.9.8m.orig/util/copy.pl
636+++ openssl-0.9.8m/util/copy.pl
637@@ -1,4 +1,4 @@
638-#!/usr/local/bin/perl
639+#!/usr/bin/perl
640
641 use Fcntl;
642
643--- openssl-0.9.8m.orig/util/mkdir-p.pl
644+++ openssl-0.9.8m/util/mkdir-p.pl
645@@ -1,4 +1,4 @@
646-#!/usr/local/bin/perl
647+#!/usr/bin/perl
648
649 # mkdir-p.pl
650
651--- openssl-0.9.8m.orig/util/mkdef.pl
652+++ openssl-0.9.8m/util/mkdef.pl
653@@ -1,4 +1,4 @@
654-#!/usr/local/bin/perl -w
655+#!/usr/bin/perl
656 #
657 # generate a .def file
658 #
659--- openssl-0.9.8m.orig/util/files.pl
660+++ openssl-0.9.8m/util/files.pl
661@@ -1,4 +1,4 @@
662-#!/usr/local/bin/perl
663+#!/usr/bin/perl
664 #
665 # used to generate the file MINFO for use by util/mk1mf.pl
666 # It is basically a list of all variables from the passed makefile
667--- openssl-0.9.8m.orig/util/mkfiles.pl
668+++ openssl-0.9.8m/util/mkfiles.pl
669@@ -1,4 +1,4 @@
670-#!/usr/local/bin/perl
671+#!/usr/bin/perl
672 #
673 # This is a hacked version of files.pl for systems that can't do a 'make files'.
674 # Do a perl util/mkminfo.pl >MINFO to build MINFO
675--- openssl-0.9.8m.orig/util/perlpath.pl
676+++ openssl-0.9.8m/util/perlpath.pl
677@@ -1,4 +1,4 @@
678-#!/usr/local/bin/perl
679+#!/usr/bin/perl
680 #
681 # modify the '#!/usr/local/bin/perl'
682 # line in all scripts that rely on perl.
683--- openssl-0.9.8m.orig/util/mk1mf.pl
684+++ openssl-0.9.8m/util/mk1mf.pl
685@@ -1,4 +1,4 @@
686-#!/usr/local/bin/perl
687+#!/usr/bin/perl
688 # A bit of an evil hack but it post processes the file ../MINFO which
689 # is generated by `make files` in the top directory.
690 # This script outputs one mega makefile that has no shell stuff or any
691--- openssl-0.9.8m.orig/util/err-ins.pl
692+++ openssl-0.9.8m/util/err-ins.pl
693@@ -1,4 +1,4 @@
694-#!/usr/local/bin/perl
695+#!/usr/bin/perl
696 #
697 # tack error codes onto the end of a file
698 #
699--- openssl-0.9.8m.orig/util/pl/Mingw32.pl
700+++ openssl-0.9.8m/util/pl/Mingw32.pl
701@@ -1,4 +1,4 @@
702-#!/usr/local/bin/perl
703+#!/usr/bin/perl
704 #
705 # Mingw32.pl -- Mingw
706 #
707--- openssl-0.9.8m.orig/util/pl/unix.pl
708+++ openssl-0.9.8m/util/pl/unix.pl
709@@ -1,4 +1,4 @@
710-#!/usr/local/bin/perl
711+#!/usr/bin/perl
712 #
713 # unix.pl - the standard unix makefile stuff.
714 #
715--- openssl-0.9.8m.orig/util/pl/netware.pl
716+++ openssl-0.9.8m/util/pl/netware.pl
717@@ -1,4 +1,4 @@
718-# Metrowerks Codewarrior or gcc / nlmconv for NetWare
719+#!/usr/bin/perl
720 #
721
722 $version_header = "crypto/opensslv.h";
723--- openssl-0.9.8m.orig/util/pl/VC-32.pl
724+++ openssl-0.9.8m/util/pl/VC-32.pl
725@@ -1,4 +1,4 @@
726-#!/usr/local/bin/perl
727+#!/usr/bin/perl
728 # VC-32.pl - unified script for Microsoft Visual C++, covering Win32,
729 # Win64 and WinCE [follow $FLAVOR variable to trace the differences].
730 #
731--- openssl-0.9.8m.orig/util/pl/OS2-EMX.pl
732+++ openssl-0.9.8m/util/pl/OS2-EMX.pl
733@@ -1,4 +1,4 @@
734-#!/usr/local/bin/perl
735+#!/usr/bin/perl
736 #
737 # OS2-EMX.pl - for EMX GCC on OS/2
738 #
739--- openssl-0.9.8m.orig/util/pl/ultrix.pl
740+++ openssl-0.9.8m/util/pl/ultrix.pl
741@@ -1,4 +1,4 @@
742-#!/usr/local/bin/perl
743+#!/usr/bin/perl
744 #
745 # linux.pl - the standard unix makefile stuff.
746 #
747--- openssl-0.9.8m.orig/util/pl/linux.pl
748+++ openssl-0.9.8m/util/pl/linux.pl
749@@ -1,4 +1,4 @@
750-#!/usr/local/bin/perl
751+#!/usr/bin/perl
752 #
753 # linux.pl - the standard unix makefile stuff.
754 #
755--- openssl-0.9.8m.orig/util/pl/BC-32.pl
756+++ openssl-0.9.8m/util/pl/BC-32.pl
757@@ -1,4 +1,4 @@
758-#!/usr/local/bin/perl
759+#!/usr/bin/perl
760 # Borland C++ builder 3 and 4 -- Janez Jere <jj@void.si>
761 #
762