summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb')
-rw-r--r--meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
new file mode 100644
index 0000000000..320716d6aa
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/cryptodev-linux_1.6.bb
@@ -0,0 +1,22 @@
1SUMMARY = "A /dev/crypto device driver"
2HOMEPAGE = "http://cryptodev-linux.org/"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "http://download.gna.org/cryptodev-linux/${BPN}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "eade38998313c25fd7934719cdf8a2ea"
10SRC_URI[sha256sum] = "75f1425c8ea1f8cae523905a5a046a35092327a6152800b0b86efc4e56fb3e2f"
11
12do_compile() {
13 :
14}
15
16# Just install cryptodev.h which is the only header file needed to be exported
17do_install() {
18 install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
19}
20
21ALLOW_EMPTY_${PN} = "1"
22BBCLASSEXTEND = "native nativesdk"