summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.5p1.bb')
-rw-r--r--meta/recipes-connectivity/openssh/openssh_6.5p1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.5p1.bb b/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
index d19cc5a6b2..3b10164a41 100644
--- a/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_6.5p1.bb
@@ -27,7 +27,9 @@ SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.
27 file://sshd.socket \ 27 file://sshd.socket \
28 file://sshd@.service \ 28 file://sshd@.service \
29 file://sshdgenkeys.service \ 29 file://sshdgenkeys.service \
30 file://volatiles.99_sshd " 30 file://volatiles.99_sshd \
31 file://add-test-support-for-busybox.patch \
32 file://run-ptest"
31 33
32PAM_SRC_URI = "file://sshd" 34PAM_SRC_URI = "file://sshd"
33 35
@@ -48,7 +50,7 @@ SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket"
48PACKAGECONFIG ??= "tcp-wrappers" 50PACKAGECONFIG ??= "tcp-wrappers"
49PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers" 51PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers"
50 52
51inherit autotools-brokensep 53inherit autotools-brokensep ptest
52 54
53# LFS support: 55# LFS support:
54CFLAGS += "-D__FILE_OFFSET_BITS=64" 56CFLAGS += "-D__FILE_OFFSET_BITS=64"
@@ -118,6 +120,11 @@ do_install_append () {
118 ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service 120 ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service
119} 121}
120 122
123do_install_ptest () {
124 sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libdir}/${PN}/sftp-server|" regress/test-exec.sh
125 cp -r regress ${D}${PTEST_PATH}
126}
127
121ALLOW_EMPTY_${PN} = "1" 128ALLOW_EMPTY_${PN} = "1"
122 129
123PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server" 130PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
@@ -132,6 +139,7 @@ FILES_${PN}-keygen = "${bindir}/ssh-keygen"
132 139
133RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen" 140RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen"
134RDEPENDS_${PN}-sshd += "${PN}-keygen ${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}" 141RDEPENDS_${PN}-sshd += "${PN}-keygen ${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
142RDEPENDS_${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make"
135 143
136CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config" 144CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
137CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config" 145CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config"