diff options
Diffstat (limited to 'meta/recipes-connectivity/openssh/openssh_6.4p1.bb')
-rw-r--r-- | meta/recipes-connectivity/openssh/openssh_6.4p1.bb | 136 |
1 files changed, 136 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_6.4p1.bb b/meta/recipes-connectivity/openssh/openssh_6.4p1.bb new file mode 100644 index 0000000000..859fdd615e --- /dev/null +++ b/meta/recipes-connectivity/openssh/openssh_6.4p1.bb | |||
@@ -0,0 +1,136 @@ | |||
1 | SUMMARY = "Secure rlogin/rsh/rcp/telnet replacement" | ||
2 | DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \ | ||
3 | Ssh (Secure Shell) is a program for logging into a remote machine \ | ||
4 | and for executing commands on a remote machine." | ||
5 | HOMEPAGE = "http://openssh.org" | ||
6 | SECTION = "console/network" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e326045657e842541d3f35aada442507" | ||
9 | |||
10 | |||
11 | DEPENDS = "zlib openssl" | ||
12 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
13 | |||
14 | RPROVIDES_${PN}-ssh = "ssh" | ||
15 | RPROVIDES_${PN}-sshd = "sshd" | ||
16 | |||
17 | RCONFLICTS_${PN} = "dropbear" | ||
18 | RCONFLICTS_${PN}-sshd = "dropbear" | ||
19 | RCONFLICTS_${PN}-keygen = "ssh-keygen" | ||
20 | |||
21 | SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \ | ||
22 | file://nostrip.patch \ | ||
23 | file://sshd_config \ | ||
24 | file://ssh_config \ | ||
25 | file://init \ | ||
26 | file://openssh-CVE-2011-4327.patch \ | ||
27 | ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ | ||
28 | file://sshd.socket \ | ||
29 | file://sshd@.service \ | ||
30 | file://sshdgenkeys.service \ | ||
31 | file://volatiles.99_sshd " | ||
32 | |||
33 | PAM_SRC_URI = "file://sshd" | ||
34 | |||
35 | SRC_URI[md5sum] = "a62b88b884df0b09b8a8c5789ac9e51b" | ||
36 | SRC_URI[sha256sum] = "5530f616513b14aea3662c4c373bafd6a97a269938674c006377e381f68975d2" | ||
37 | |||
38 | inherit useradd update-rc.d update-alternatives systemd | ||
39 | |||
40 | USERADD_PACKAGES = "${PN}-sshd" | ||
41 | USERADD_PARAM_${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd" | ||
42 | INITSCRIPT_PACKAGES = "${PN}-sshd" | ||
43 | INITSCRIPT_NAME_${PN}-sshd = "sshd" | ||
44 | INITSCRIPT_PARAMS_${PN}-sshd = "defaults 9" | ||
45 | |||
46 | SYSTEMD_PACKAGES = "${PN}-sshd" | ||
47 | SYSTEMD_SERVICE_${PN}-sshd = "sshd.socket sshd@.service sshdgenkeys.service" | ||
48 | |||
49 | PACKAGECONFIG ??= "tcp-wrappers" | ||
50 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,,tcp-wrappers" | ||
51 | |||
52 | inherit autotools | ||
53 | |||
54 | # LFS support: | ||
55 | CFLAGS += "-D__FILE_OFFSET_BITS=64" | ||
56 | export LD = "${CC}" | ||
57 | |||
58 | EXTRA_OECONF = "--with-rand-helper=no \ | ||
59 | ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \ | ||
60 | --without-zlib-version-check \ | ||
61 | --with-privsep-path=/var/run/sshd \ | ||
62 | --sysconfdir=${sysconfdir}/ssh \ | ||
63 | --with-xauth=/usr/bin/xauth" | ||
64 | |||
65 | # This is a workaround for uclibc because including stdio.h | ||
66 | # pulls in pthreads.h and causes conflicts in function prototypes. | ||
67 | # This results in compilation failure, so unless this is fixed, | ||
68 | # disable pam for uclibc. | ||
69 | EXTRA_OECONF_append_libc-uclibc=" --without-pam" | ||
70 | |||
71 | do_configure_prepend () { | ||
72 | if [ ! -e acinclude.m4 -a -e aclocal.m4 ]; then | ||
73 | cp aclocal.m4 acinclude.m4 | ||
74 | fi | ||
75 | } | ||
76 | |||
77 | do_compile_append () { | ||
78 | install -m 0644 ${WORKDIR}/sshd_config ${S}/ | ||
79 | install -m 0644 ${WORKDIR}/ssh_config ${S}/ | ||
80 | } | ||
81 | |||
82 | do_install_append () { | ||
83 | for i in ${DISTRO_FEATURES}; | ||
84 | do | ||
85 | if [ ${i} = "pam" ]; then | ||
86 | install -d ${D}${sysconfdir}/pam.d | ||
87 | install -m 0755 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd | ||
88 | fi | ||
89 | done | ||
90 | install -d ${D}${sysconfdir}/init.d | ||
91 | install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd | ||
92 | rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin | ||
93 | rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir} | ||
94 | install -d ${D}/${sysconfdir}/default/volatiles | ||
95 | install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd | ||
96 | |||
97 | # Create config files for read-only rootfs | ||
98 | install -d ${D}${sysconfdir}/ssh | ||
99 | install -m 644 ${WORKDIR}/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly | ||
100 | sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly | ||
101 | echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly | ||
102 | echo "HostKey /var/run/ssh/ssh_host_dsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly | ||
103 | echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly | ||
104 | |||
105 | install -d ${D}${systemd_unitdir}/system | ||
106 | install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_unitdir}/system | ||
107 | install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_unitdir}/system | ||
108 | install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_unitdir}/system | ||
109 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
110 | -e 's,@SBINDIR@,${sbindir},g' \ | ||
111 | -e 's,@BINDIR@,${bindir},g' \ | ||
112 | ${D}${systemd_unitdir}/system/sshd.socket ${D}${systemd_unitdir}/system/*.service | ||
113 | } | ||
114 | |||
115 | ALLOW_EMPTY_${PN} = "1" | ||
116 | |||
117 | PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server" | ||
118 | FILES_${PN}-scp = "${bindir}/scp.${BPN}" | ||
119 | FILES_${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config" | ||
120 | FILES_${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd" | ||
121 | FILES_${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd" | ||
122 | FILES_${PN}-sftp = "${bindir}/sftp" | ||
123 | FILES_${PN}-sftp-server = "${libexecdir}/sftp-server" | ||
124 | FILES_${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*" | ||
125 | FILES_${PN}-keygen = "${bindir}/ssh-keygen" | ||
126 | |||
127 | RDEPENDS_${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen" | ||
128 | RDEPENDS_${PN}-sshd += "${PN}-keygen" | ||
129 | |||
130 | CONFFILES_${PN}-sshd = "${sysconfdir}/ssh/sshd_config" | ||
131 | CONFFILES_${PN}-ssh = "${sysconfdir}/ssh/ssh_config" | ||
132 | |||
133 | ALTERNATIVE_PRIORITY = "90" | ||
134 | ALTERNATIVE_${PN}-scp = "scp" | ||
135 | ALTERNATIVE_${PN}-ssh = "ssh" | ||
136 | |||