summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb114
1 files changed, 114 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb
new file mode 100644
index 0000000000..d312349fe4
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.3.1.bb
@@ -0,0 +1,114 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
12RDEPENDS_${PN}-client = "rpcbind bash"
13RDEPENDS_${PN} = "${PN}-client bash"
14RRECOMMENDS_${PN} = "kernel-module-nfsd"
15
16inherit useradd
17
18USERADD_PACKAGES = "${PN}-client"
19USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
20 --shell /bin/false --user-group rpcuser"
21
22SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
23 file://0001-configure-Allow-to-explicitly-disable-nfsidmap.patch \
24 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
25 file://nfsserver \
26 file://nfscommon \
27 file://nfs-utils.conf \
28 file://nfs-server.service \
29 file://nfs-mountd.service \
30 file://nfs-statd.service \
31 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
32"
33
34SRC_URI[md5sum] = "8de676b9ff34b8f9addc1d0800fabdf8"
35SRC_URI[sha256sum] = "ff79d70b7b58b2c8f9b798c58721127e82bb96022adc04a5c4cb251630e696b8"
36
37PARALLEL_MAKE = ""
38
39# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
40# pull in the remainder of the dependencies.
41
42INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
43INITSCRIPT_NAME = "nfsserver"
44INITSCRIPT_PARAMS = "defaults"
45INITSCRIPT_NAME_${PN}-client = "nfscommon"
46INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
47
48inherit autotools-brokensep update-rc.d systemd pkgconfig
49
50SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
51SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
52SYSTEMD_AUTO_ENABLE = "disable"
53
54# --enable-uuid is need for cross-compiling
55EXTRA_OECONF = "--with-statduser=rpcuser \
56 --enable-mountconfig \
57 --enable-libmount-mount \
58 --disable-nfsv41 \
59 --enable-uuid \
60 --disable-gss \
61 --disable-tirpc \
62 --disable-nfsdcltrack \
63 --with-statdpath=/var/lib/nfs/statd \
64 "
65
66PACKAGECONFIG ??= "tcp-wrappers"
67PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
68PACKAGECONFIG[nfsidmap] = "--enable-nfsidmap,--disable-nfsidmap,keyutils"
69
70INHIBIT_AUTO_STAGE = "1"
71
72PACKAGES =+ "${PN}-client ${PN}-stats"
73FILES_${PN}-client = "${base_sbindir}/*mount.nfs* ${sbindir}/*statd \
74 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
75 ${sbindir}/showmount ${sbindir}/nfsstat \
76 ${localstatedir}/lib/nfs \
77 ${sysconfdir}/nfs-utils.conf \
78 ${sysconfdir}/init.d/nfscommon \
79 ${systemd_unitdir}/system/nfs-statd.service"
80FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
81RDEPENDS_${PN}-stats = "python"
82
83# Make clean needed because the package comes with
84# precompiled 64-bit objects that break the build
85do_compile_prepend() {
86 make clean
87}
88
89do_install_append () {
90 install -d ${D}${sysconfdir}/init.d
91 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
92 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
93
94 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
95 install -d ${D}${systemd_unitdir}/system
96 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
97 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
98 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
99 sed -i -e 's,@SBINDIR@,${sbindir},g' \
100 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
101 ${D}${systemd_unitdir}/system/*.service
102
103 # kernel code as of 3.8 hard-codes this path as a default
104 install -d ${D}/var/lib/nfs/v4recovery
105
106 # chown the directories and files
107 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
108 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
109
110 # the following are built by CC_FOR_BUILD
111 rm -f ${D}${sbindir}/rpcdebug
112 rm -f ${D}${sbindir}/rpcgen
113 rm -f ${D}${sbindir}/locktest
114}