summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb92
1 files changed, 92 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
new file mode 100644
index 0000000000..e3e8136c27
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.8.bb
@@ -0,0 +1,92 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3"
12RDEPENDS_${PN} = "rpcbind"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.bz2 \
16 file://nfs-utils-1.0.6-uclibc.patch \
17 file://nfs-utils-1.2.3-sm-notify-res_init.patch \
18 file://nfsserver \
19 file://nfs-utils.conf \
20 file://nfs-server.service \
21 file://nfs-mountd.service \
22 file://nfs-statd.service "
23
24SRC_URI[md5sum] = "6e7d97de51e428a0b8698c16ca23db77"
25SRC_URI[sha256sum] = "1cc8f02a633eddbf0a1d93421f331479c4cdab4c5ab33b8bf8c7c369f9156ac6"
26
27PARALLEL_MAKE = ""
28
29# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
30# pull in the remainder of the dependencies.
31
32INITSCRIPT_NAME = "nfsserver"
33# The server has no dependencies at the user run levels, so just put
34# it in at the default levels. It must be terminated before the network
35# in the shutdown levels, but that works fine.
36INITSCRIPT_PARAMS = "defaults"
37
38inherit autotools update-rc.d systemd
39
40SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service nfs-statd.service"
41SYSTEMD_AUTO_ENABLE = "disable"
42
43# --enable-uuid is need for cross-compiling
44EXTRA_OECONF = "--with-statduser=nobody \
45 --enable-mountconfig \
46 --enable-libmount-mount \
47 --disable-nfsv41 \
48 --enable-uuid \
49 --disable-gss \
50 --disable-tirpc \
51 --disable-nfsdcltrack \
52 --with-statdpath=/var/lib/nfs/statd \
53 "
54
55PACKAGECONFIG ??= "tcp-wrappers"
56PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
57
58INHIBIT_AUTO_STAGE = "1"
59
60PACKAGES =+ "${PN}-client ${PN}-stats"
61FILES_${PN}-client = "${base_sbindir}/*mount.nfs*"
62FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
63RDEPENDS_${PN}-stats = "python"
64
65# Make clean needed because the package comes with
66# precompiled 64-bit objects that break the build
67do_compile_prepend() {
68 make clean
69}
70
71do_install_append () {
72 install -d ${D}${sysconfdir}/init.d
73 install -d ${D}${localstatedir}/lib/nfs/statd
74 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
75
76 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
77 install -d ${D}${systemd_unitdir}/system
78 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
79 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
80 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
81 sed -i -e 's,@SBINDIR@,${sbindir},g' \
82 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
83 ${D}${systemd_unitdir}/system/*.service
84
85 # kernel code as of 3.8 hard-codes this path as a default
86 install -d ${D}/var/lib/nfs/v4recovery
87
88 # the following are built by CC_FOR_BUILD
89 rm -f ${D}${sbindir}/rpcdebug
90 rm -f ${D}${sbindir}/rpcgen
91 rm -f ${D}${sbindir}/locktest
92}