summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
new file mode 100644
index 0000000000..4056dda65c
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb
@@ -0,0 +1,53 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6PRIORITY = "optional"
7
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
10
11# util-linux for libblkid
12DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
13RDEPENDS = "portmap"
14RRECOMMENDS = "kernel-module-nfsd"
15
16PR = "r0"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
19 file://nfs-utils-1.0.6-uclibc.patch \
20 file://nfsserver"
21
22PARALLEL_MAKE = ""
23
24# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
25# pull in the remainder of the dependencies.
26
27INITSCRIPT_NAME = "nfsserver"
28# The server has no dependencies at the user run levels, so just put
29# it in at the default levels. It must be terminated before the network
30# in the shutdown levels, but that works fine.
31INITSCRIPT_PARAMS = "defaults"
32
33inherit autotools update-rc.d
34
35# --enable-uuid is need for cross-compiling
36EXTRA_OECONF = "--with-statduser=nobody \
37 --enable-nfsv41 \
38 --enable-uuid \
39 --disable-gss \
40 --disable-tirpc \
41 --with-statedir=/var/lib/nfs"
42
43INHIBIT_AUTO_STAGE = "1"
44
45do_install_append () {
46 install -d ${D}${sysconfdir}/init.d
47 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
48
49 # the following are built by CC_FOR_BUILD
50 rm -f ${D}${sbindir}/rpcdebug
51 rm -f ${D}${sbindir}/rpcgen
52 rm -f ${D}${sbindir}/locktest
53}