summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/kea/kea_1.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/kea/kea_1.8.2.bb')
-rw-r--r--meta/recipes-connectivity/kea/kea_1.8.2.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-connectivity/kea/kea_1.8.2.bb b/meta/recipes-connectivity/kea/kea_1.8.2.bb
index fe10d90620..f1bbbc49e7 100644
--- a/meta/recipes-connectivity/kea/kea_1.8.2.bb
+++ b/meta/recipes-connectivity/kea/kea_1.8.2.bb
@@ -28,24 +28,24 @@ inherit autotools systemd update-rc.d upstream-version-is-even
28INITSCRIPT_NAME = "kea-dhcp4-server" 28INITSCRIPT_NAME = "kea-dhcp4-server"
29INITSCRIPT_PARAMS = "defaults 30" 29INITSCRIPT_PARAMS = "defaults 30"
30 30
31SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service" 31SYSTEMD_SERVICE:${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
32SYSTEMD_AUTO_ENABLE = "disable" 32SYSTEMD_AUTO_ENABLE = "disable"
33 33
34DEBUG_OPTIMIZATION_remove_mips = " -Og" 34DEBUG_OPTIMIZATION:remove:mips = " -Og"
35DEBUG_OPTIMIZATION_append_mips = " -O" 35DEBUG_OPTIMIZATION:append:mips = " -O"
36BUILD_OPTIMIZATION_remove_mips = " -Og" 36BUILD_OPTIMIZATION:remove:mips = " -Og"
37BUILD_OPTIMIZATION_append_mips = " -O" 37BUILD_OPTIMIZATION:append:mips = " -O"
38 38
39DEBUG_OPTIMIZATION_remove_mipsel = " -Og" 39DEBUG_OPTIMIZATION:remove:mipsel = " -Og"
40DEBUG_OPTIMIZATION_append_mipsel = " -O" 40DEBUG_OPTIMIZATION:append:mipsel = " -O"
41BUILD_OPTIMIZATION_remove_mipsel = " -Og" 41BUILD_OPTIMIZATION:remove:mipsel = " -Og"
42BUILD_OPTIMIZATION_append_mipsel = " -O" 42BUILD_OPTIMIZATION:append:mipsel = " -O"
43 43
44EXTRA_OECONF = "--with-boost-libs=-lboost_system \ 44EXTRA_OECONF = "--with-boost-libs=-lboost_system \
45 --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \ 45 --with-log4cplus=${STAGING_DIR_TARGET}${prefix} \
46 --with-openssl=${STAGING_DIR_TARGET}${prefix}" 46 --with-openssl=${STAGING_DIR_TARGET}${prefix}"
47 47
48do_configure_prepend() { 48do_configure:prepend() {
49 # replace abs_top_builddir to avoid introducing the build path 49 # replace abs_top_builddir to avoid introducing the build path
50 # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target 50 # don't expand the abs_top_builddir on the target as the abs_top_builddir is meanlingless on the target
51 find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g" 51 find ${S} -type f -name *.sh.in | xargs sed -i "s:@abs_top_builddir@:@abs_top_builddir_placeholder@:g"
@@ -53,11 +53,11 @@ do_configure_prepend() {
53} 53}
54 54
55# patch out build host paths for reproducibility 55# patch out build host paths for reproducibility
56do_compile_prepend_class-target() { 56do_compile:prepend:class-target() {
57 sed -i -e "s,${WORKDIR},,g" ${B}/config.report 57 sed -i -e "s,${WORKDIR},,g" ${B}/config.report
58} 58}
59 59
60do_install_append() { 60do_install:append() {
61 install -d ${D}${sysconfdir}/init.d 61 install -d ${D}${sysconfdir}/init.d
62 install -d ${D}${systemd_system_unitdir} 62 install -d ${D}${systemd_system_unitdir}
63 63
@@ -68,13 +68,13 @@ do_install_append() {
68 ${D}${systemd_system_unitdir}/kea-dhcp*service ${D}${sbindir}/keactrl 68 ${D}${systemd_system_unitdir}/kea-dhcp*service ${D}${sbindir}/keactrl
69} 69}
70 70
71do_install_append() { 71do_install:append() {
72 rm -rf "${D}${localstatedir}" 72 rm -rf "${D}${localstatedir}"
73} 73}
74 74
75CONFFILES_${PN} = "${sysconfdir}/kea/keactrl.conf" 75CONFFILES:${PN} = "${sysconfdir}/kea/keactrl.conf"
76 76
77FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a" 77FILES:${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
78FILES_${PN} += "${libdir}/hooks/*.so" 78FILES:${PN} += "${libdir}/hooks/*.so"
79 79
80PARALLEL_MAKEINST = "" 80PARALLEL_MAKEINST = ""