summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb')
-rw-r--r--meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb b/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
new file mode 100644
index 0000000000..07b6b90e7c
--- /dev/null
+++ b/meta/recipes-connectivity/gupnp/gupnp_0.16.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "UPnP framework"
2DESCRIPTION = "GUPnP is an elegant, object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. The GUPnP API is intended to be easy to use, efficient and flexible. It provides the same set of features as libupnp, but shields the developer from most of UPnP's internals."
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
5 file://libgupnp/gupnp.h;beginline=1;endline=20;md5=28c49b17d623afc3335efc2e511879e1"
6DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2 gnome-icon-theme"
7
8SRC_URI = "http://gupnp.org/sites/all/files/sources/${BPN}-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "61b240c1a9fdf8ca82c5c3adde0d6757"
11SRC_URI[sha256sum] = "1b77201866b7632fb68bc2a3bdea22ef8ead34ba850b3ee367797432cfc0f04a"
12
13PR = "r0"
14
15EXTRA_OECONF = "--disable-introspection"
16
17inherit autotools pkgconfig
18
19FILES_${PN} = "${libdir}/*.so.*"
20FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
21
22SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
23
24gupnp_sysroot_preprocess () {
25 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
26 install -m 755 ${D}${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${bindir_crossscripts}/
27}
28