summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb')
-rw-r--r--meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb b/meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb
new file mode 100644
index 0000000000..2a12e5ce24
--- /dev/null
+++ b/meta/recipes-connectivity/gupnp/gupnp_0.13.2.bb
@@ -0,0 +1,17 @@
1LICENSE = "LGPL"
2DEPENDS = "e2fsprogs gssdp libsoup-2.4 libxml2"
3
4SRC_URI = "http://gupnp.org/sources/${PN}/${PN}-${PV}.tar.gz"
5PR = "r1"
6
7inherit autotools pkgconfig
8
9FILES_${PN} = "${libdir}/*.so.*"
10FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
11
12SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
13
14gupnp_sysroot_preprocess () {
15 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
16 install -m 755 ${D}${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
17}