summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/farsight/libnice_0.0.6.bb')
-rw-r--r--meta/recipes-connectivity/farsight/libnice_0.0.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/farsight/libnice_0.0.6.bb b/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
new file mode 100644
index 0000000000..809b691af7
--- /dev/null
+++ b/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)."
2HOMEPAGE = "http://nice.freedesktop.org/wiki/"
3SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
4
5LICENSE = "LGPL/MPL"
6DEPENDS = "glib-2.0 gstreamer"
7
8inherit autotools
9AUTOTOOLS_STAGE_PKGCONFIG = "1"
10
11FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
12FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*a"
13FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
14
15do_compile_append() {
16 for i in $(find ${S} -name "*.pc") ; do
17 sed -i -e s:${STAGING_DIR_TARGET}::g \
18 -e s:/${TARGET_SYS}::g \
19 $i
20 done
21}
22
23