summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/connman/connman-gnome_0.5.bb')
-rw-r--r--meta/recipes-connectivity/connman/connman-gnome_0.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/connman/connman-gnome_0.5.bb b/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
new file mode 100644
index 0000000000..6958ee57bb
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman-gnome_0.5.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "gtk frontend for connman"
2HOMEPAGE = "http://connman.net/"
3SECTION = "libs/network"
4LICENSE = "GPLv2 & LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
6 file://properties/main.c;beginline=1;endline=20;md5=50c77c81871308b033ab7a1504626afb \
7 file://common/connman-dbus.c;beginline=1;endline=20;md5=de6b485c0e717a0236402d220187717a"
8DEPENDS = "gtk+ dbus"
9PR = "r0"
10
11RRECOMMENDS_${PN} = "python python-dbus connman connman-plugin-ethernet connman-plugin-loopback connman-plugin-udhcp connman-plugin-wifi connman-plugin-fake connman-plugin-bluetooth connman-plugin-dnsproxy"
12
13SRC_URI = "http://www.kernel.org/pub/linux/network/connman/connman-gnome-${PV}.tar.gz \
14 file://connman-gnome.patch \
15 file://connman-applet.desktop"
16
17inherit autotools gtk-icon-cache
18
19do_install_append() {
20 install -d ${D}${datadir}/applications/
21 install ${WORKDIR}/connman-applet.desktop ${D}${datadir}/applications/
22}