summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.99.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.99.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.99.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.99.bb b/meta/recipes-connectivity/bluez/bluez4_4.99.bb
new file mode 100644
index 0000000000..97c77b419b
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.99.bb
@@ -0,0 +1,35 @@
1require bluez4.inc
2
3PR = "r0"
4
5SRC_URI += "file://bluetooth.conf \
6 file://sbc_mmx.patch \
7 "
8
9SRC_URI[md5sum] = "570aa10692ed890aa0a4297b37824912"
10SRC_URI[sha256sum] = "d884b9aa5d3d9653c076b7646ca14a3e43eb84bccfe8193c49690f802bbd827c"
11
12do_install_append() {
13 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
14 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
15 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
16 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
17 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
18}
19
20RDEPENDS_${PN}-dev = "bluez-hcidump"
21
22PACKAGES =+ "libasound-module-bluez"
23
24FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
25FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${base_libdir}/systemd/"
26FILES_${PN}-dev += "\
27 ${libdir}/bluetooth/plugins/*.la \
28 ${libdir}/alsa-lib/*.la \
29"
30
31FILES_${PN}-dbg += "\
32 ${libdir}/bluetooth/plugins/.debug \
33 ${libdir}/*/.debug \
34 ${base_libdir}/udev/.debug \
35 "