summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.96.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.96.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.96.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.96.bb b/meta/recipes-connectivity/bluez/bluez4_4.96.bb
new file mode 100644
index 0000000000..ebd2849484
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.96.bb
@@ -0,0 +1,73 @@
1SUMMARY = "Linux Bluetooth Stack Userland V4"
2DESCRIPTION = "Linux Bluetooth stack V4 userland components. These include a system configurations, daemons, tools and system libraries."
3HOMEPAGE = "http://www.bluez.org"
4SECTION = "libs"
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
7 file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
8 file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
9 file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
10DEPENDS = "gst-plugins-base alsa-lib libusb dbus-glib libnl"
11RDEPENDS_${PN}-dev = "bluez-hcidump"
12
13# For angstrom we want this to replace at least bluez-libs
14PROVIDES_append_angstrom = " bluez-utils bluez-libs"
15
16ASNEEDED = ""
17
18PR = "r0"
19
20SRC_URI = "\
21 ${KERNELORG_MIRROR}/linux/bluetooth/bluez-${PV}.tar.gz \
22 file://bluetooth.conf \
23"
24
25SRC_URI[md5sum] = "296111afac49e3f9035085ac14daf518"
26SRC_URI[sha256sum] = "c06fd50fd77909cad55e3181a42c6bce7cfcf7abb8cd87871c13d0d70f87fa99"
27S = "${WORKDIR}/bluez-${PV}"
28
29inherit autotools
30
31EXTRA_OECONF = "\
32 --enable-gstreamer \
33 --enable-alsa \
34 --enable-usb \
35 --enable-netlink \
36 --enable-tools \
37 --enable-bccmd \
38 --enable-hid2hci \
39 --enable-dfutool \
40 --enable-hidd \
41 --enable-pandd \
42 --enable-dund \
43 --disable-cups \
44 --enable-test \
45 --enable-manpages \
46 --enable-configfiles \
47 --enable-initscripts \
48 --disable-pcmciarules \
49"
50
51do_install_append() {
52 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
53 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
54 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
55 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
56 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
57}
58
59PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
60
61FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
62FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
63FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
64FILES_${PN}-dev += "\
65 ${libdir}/bluetooth/plugins/*.la \
66 ${libdir}/alsa-lib/*.la \
67 ${libdir}/gstreamer-0.10/*.la \
68"
69
70FILES_${PN}-dbg += "\
71 ${libdir}/bluetooth/plugins/.debug \
72 ${libdir}/*/.debug \
73"