summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bluez/bluez4_4.82.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.82.bb')
-rw-r--r--meta/recipes-connectivity/bluez/bluez4_4.82.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.82.bb b/meta/recipes-connectivity/bluez/bluez4_4.82.bb
new file mode 100644
index 0000000000..9189a585f4
--- /dev/null
+++ b/meta/recipes-connectivity/bluez/bluez4_4.82.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Linux Bluetooth Stack Userland V4"
2DESCRIPTION = "Linux Bluetooth stack V4 userland components. These include a system configurations, daemons, tools and system libraries."
3HOMEPAGE = "http://www.bluez.org"
4SECTION = "libs"
5PRIORITY = "optional"
6LICENSE = "GPLv2+ & LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
8 file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \
9 file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \
10 file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191"
11DEPENDS = "gst-plugins-base alsa-lib libusb dbus-glib libnl"
12RDEPENDS_${PN}-dev = "bluez-hcidump"
13
14# For angstrom we want this to replace at least bluez-libs
15PROVIDES_append_angstrom = " bluez-utils bluez-libs"
16
17ASNEEDED = ""
18
19PR = "r0"
20
21SRC_URI = "\
22 http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
23 file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
24 file://sbc-thumb.patch;patch=1 \
25 file://bluetooth.conf \
26"
27
28SRC_URI[md5sum] = "b9e5de607e5e43c868c35c68fe6f189f"
29SRC_URI[sha256sum] = "75dc506f5346e1eb803f44294ae02406e806e309d9c9bda1de7ed235ff794b6d"
30S = "${WORKDIR}/bluez-${PV}"
31
32inherit autotools
33
34EXTRA_OECONF = "\
35 --enable-gstreamer \
36 --enable-alsa \
37 --enable-usb \
38 --enable-netlink \
39 --enable-tools \
40 --enable-bccmd \
41 --enable-hid2hci \
42 --enable-dfutool \
43 --enable-hidd \
44 --enable-pandd \
45 --enable-dund \
46 --disable-cups \
47 --enable-test \
48 --enable-manpages \
49 --enable-configfiles \
50 --enable-initscripts \
51 --disable-pcmciarules \
52"
53
54do_install_append() {
55 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
56 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
57 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
58 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
59 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
60}
61
62PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
63
64FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
65FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
66FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
67FILES_${PN}-dev += "\
68 ${libdir}/bluetooth/plugins/*.la \
69 ${libdir}/alsa-lib/*.la \
70 ${libdir}/gstreamer-0.10/*.la \
71"
72
73FILES_${PN}-dbg += "\
74 ${libdir}/bluetooth/plugins/.debug \
75 ${libdir}/*/.debug \
76"