diff options
Diffstat (limited to 'meta/recipes-connectivity/bluez/bluez4_4.66.bb')
-rw-r--r-- | meta/recipes-connectivity/bluez/bluez4_4.66.bb | 72 |
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bluez/bluez4_4.66.bb b/meta/recipes-connectivity/bluez/bluez4_4.66.bb new file mode 100644 index 0000000000..7abf0faa65 --- /dev/null +++ b/meta/recipes-connectivity/bluez/bluez4_4.66.bb | |||
@@ -0,0 +1,72 @@ | |||
1 | DESCRIPTION = "Linux Bluetooth Stack Userland V4" | ||
2 | HOMEPAGE = "http://www.bluez.org" | ||
3 | SECTION = "libs" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "GPLv2+ & LGPLv2.1+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ | ||
7 | file://COPYING.LIB;md5=fb504b67c50331fc78734fed90fb0e09 \ | ||
8 | file://src/main.c;beginline=1;endline=24;md5=9bc54b93cd7e17bf03f52513f39f926e \ | ||
9 | file://sbc/sbc.c;beginline=1;endline=25;md5=1a40781ed30d50d8639323a184aeb191" | ||
10 | DEPENDS = "gst-plugins-base alsa-lib libusb dbus-glib libnl" | ||
11 | |||
12 | # For angstrom we want this to replace at least bluez-libs | ||
13 | PROVIDES_append_angstrom = " bluez-utils bluez-libs" | ||
14 | |||
15 | ASNEEDED = "" | ||
16 | |||
17 | PR = "r0" | ||
18 | |||
19 | SRC_URI = "\ | ||
20 | http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \ | ||
21 | file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \ | ||
22 | file://sbc-thumb.patch;patch=1 \ | ||
23 | file://bluetooth.conf \ | ||
24 | " | ||
25 | S = "${WORKDIR}/bluez-${PV}" | ||
26 | |||
27 | inherit autotools | ||
28 | AUTOTOOLS_STAGE_PKGCONFIG = "1" | ||
29 | |||
30 | EXTRA_OECONF = "\ | ||
31 | --enable-gstreamer \ | ||
32 | --enable-alsa \ | ||
33 | --enable-usb \ | ||
34 | --enable-netlink \ | ||
35 | --enable-tools \ | ||
36 | --enable-bccmd \ | ||
37 | --enable-hid2hci \ | ||
38 | --enable-dfutool \ | ||
39 | --enable-hidd \ | ||
40 | --enable-pandd \ | ||
41 | --enable-dund \ | ||
42 | --disable-cups \ | ||
43 | --enable-test \ | ||
44 | --enable-manpages \ | ||
45 | --enable-configfiles \ | ||
46 | --enable-initscripts \ | ||
47 | --disable-pcmciarules \ | ||
48 | " | ||
49 | |||
50 | do_install_append() { | ||
51 | install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/ | ||
52 | install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/ | ||
53 | install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/ | ||
54 | # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT | ||
55 | install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/ | ||
56 | } | ||
57 | |||
58 | PACKAGES =+ "gst-plugin-bluez libasound-module-bluez" | ||
59 | |||
60 | FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so" | ||
61 | FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so" | ||
62 | FILES_${PN} += "${libdir}/bluetooth/plugins/*.so" | ||
63 | FILES_${PN}-dev += "\ | ||
64 | ${libdir}/bluetooth/plugins/*.la \ | ||
65 | ${libdir}/alsa-lib/*.la \ | ||
66 | ${libdir}/gstreamer-0.10/*.la \ | ||
67 | " | ||
68 | |||
69 | FILES_${PN}-dbg += "\ | ||
70 | ${libdir}/bluetooth/plugins/.debug \ | ||
71 | ${libdir}/*/.debug \ | ||
72 | " | ||