diff options
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.16.23.bb')
-rw-r--r-- | meta/recipes-connectivity/bind/bind_9.16.23.bb | 129 |
1 files changed, 129 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.16.23.bb b/meta/recipes-connectivity/bind/bind_9.16.23.bb new file mode 100644 index 0000000000..c1bf250c26 --- /dev/null +++ b/meta/recipes-connectivity/bind/bind_9.16.23.bb | |||
@@ -0,0 +1,129 @@ | |||
1 | SUMMARY = "ISC Internet Domain Name Server" | ||
2 | HOMEPAGE = "https://www.isc.org/bind/" | ||
3 | DESCRIPTION = "BIND 9 provides a full-featured Domain Name Server system" | ||
4 | SECTION = "console/network" | ||
5 | |||
6 | LICENSE = "MPL-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=ef10b4de6371115dcecdc38ca2af4561" | ||
8 | |||
9 | DEPENDS = "openssl libcap zlib libuv" | ||
10 | |||
11 | SRC_URI = "https://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.xz \ | ||
12 | file://conf.patch \ | ||
13 | file://named.service \ | ||
14 | file://bind9 \ | ||
15 | file://generate-rndc-key.sh \ | ||
16 | file://make-etc-initd-bind-stop-work.patch \ | ||
17 | file://init.d-add-support-for-read-only-rootfs.patch \ | ||
18 | file://bind-ensure-searching-for-json-headers-searches-sysr.patch \ | ||
19 | file://0001-named-lwresd-V-and-start-log-hide-build-options.patch \ | ||
20 | file://0001-avoid-start-failure-with-bind-user.patch \ | ||
21 | " | ||
22 | |||
23 | SRC_URI[sha256sum] = "dedb5e27aa9cb6a9ce3e872845887ff837b99e4e9a91a5e2fcd67cf6e1ef173c" | ||
24 | |||
25 | UPSTREAM_CHECK_URI = "https://ftp.isc.org/isc/bind9/" | ||
26 | # stay at 9.16 follow the ESV versions divisible by 4 | ||
27 | UPSTREAM_CHECK_REGEX = "(?P<pver>9.(16|20|24|28)(\.\d+)+(-P\d+)*)/" | ||
28 | |||
29 | # Issue only affects dhcpd with recent bind versions. We don't ship dhcpd anymore | ||
30 | # so the issue doesn't affect us. | ||
31 | CVE_CHECK_WHITELIST += "CVE-2019-6470" | ||
32 | |||
33 | inherit autotools update-rc.d systemd useradd pkgconfig multilib_header update-alternatives | ||
34 | |||
35 | # PACKAGECONFIGs readline and libedit should NOT be set at same time | ||
36 | PACKAGECONFIG ?= "readline" | ||
37 | PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--without-libxml2,libxml2" | ||
38 | PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline" | ||
39 | PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit" | ||
40 | PACKAGECONFIG[python3] = "--with-python=yes --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native," | ||
41 | |||
42 | EXTRA_OECONF = " --with-libtool --disable-devpoll --disable-auto-validation --enable-epoll \ | ||
43 | --with-gssapi=no --with-lmdb=no --with-zlib \ | ||
44 | --sysconfdir=${sysconfdir}/bind \ | ||
45 | --with-openssl=${STAGING_DIR_HOST}${prefix} \ | ||
46 | " | ||
47 | LDFLAGS:append = " -lz" | ||
48 | |||
49 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native distutils3-base', '', d)} | ||
50 | |||
51 | # dhcp needs .la so keep them | ||
52 | REMOVE_LIBTOOL_LA = "0" | ||
53 | |||
54 | USERADD_PACKAGES = "${PN}" | ||
55 | USERADD_PARAM:${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \ | ||
56 | --user-group bind" | ||
57 | |||
58 | INITSCRIPT_NAME = "bind" | ||
59 | INITSCRIPT_PARAMS = "defaults" | ||
60 | |||
61 | SYSTEMD_SERVICE:${PN} = "named.service" | ||
62 | |||
63 | do_install:append() { | ||
64 | |||
65 | install -d -o bind "${D}${localstatedir}/cache/bind" | ||
66 | install -d "${D}${sysconfdir}/bind" | ||
67 | install -d "${D}${sysconfdir}/init.d" | ||
68 | install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/" | ||
69 | install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind" | ||
70 | if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then | ||
71 | sed -i -e '1s,#!.*python3,#! /usr/bin/python3,' \ | ||
72 | ${D}${sbindir}/dnssec-coverage \ | ||
73 | ${D}${sbindir}/dnssec-checkds \ | ||
74 | ${D}${sbindir}/dnssec-keymgr | ||
75 | fi | ||
76 | |||
77 | # Install systemd related files | ||
78 | install -d ${D}${sbindir} | ||
79 | install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir} | ||
80 | install -d ${D}${systemd_system_unitdir} | ||
81 | install -m 0644 ${WORKDIR}/named.service ${D}${systemd_system_unitdir} | ||
82 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
83 | -e 's,@SBINDIR@,${sbindir},g' \ | ||
84 | ${D}${systemd_system_unitdir}/named.service | ||
85 | |||
86 | install -d ${D}${sysconfdir}/default | ||
87 | install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default | ||
88 | |||
89 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | ||
90 | install -d ${D}${sysconfdir}/tmpfiles.d | ||
91 | echo "d /run/named 0755 bind bind - -" > ${D}${sysconfdir}/tmpfiles.d/bind.conf | ||
92 | fi | ||
93 | |||
94 | oe_multilib_header isc/platform.h | ||
95 | } | ||
96 | |||
97 | CONFFILES:${PN} = " \ | ||
98 | ${sysconfdir}/bind/named.conf \ | ||
99 | ${sysconfdir}/bind/named.conf.local \ | ||
100 | ${sysconfdir}/bind/named.conf.options \ | ||
101 | ${sysconfdir}/bind/db.0 \ | ||
102 | ${sysconfdir}/bind/db.127 \ | ||
103 | ${sysconfdir}/bind/db.empty \ | ||
104 | ${sysconfdir}/bind/db.local \ | ||
105 | ${sysconfdir}/bind/db.root \ | ||
106 | " | ||
107 | |||
108 | ALTERNATIVE:${PN}-utils = "nslookup" | ||
109 | ALTERNATIVE_LINK_NAME[nslookup] = "${bindir}/nslookup" | ||
110 | ALTERNATIVE_PRIORITY = "100" | ||
111 | |||
112 | PACKAGE_BEFORE_PN += "${PN}-utils" | ||
113 | FILES:${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/mdig ${bindir}/nslookup ${bindir}/nsupdate" | ||
114 | FILES:${PN}-dev += "${bindir}/isc-config.h" | ||
115 | FILES:${PN} += "${sbindir}/generate-rndc-key.sh" | ||
116 | |||
117 | PACKAGE_BEFORE_PN += "${PN}-libs" | ||
118 | # special arrangement below due to | ||
119 | # https://github.com/isc-projects/bind9/commit/0e25af628cd776f98c04fc4cc59048f5448f6c88 | ||
120 | FILES_SOLIBSDEV = "${libdir}/*[!0-9].so ${libdir}/libbind9.so" | ||
121 | FILES:${PN}-libs = "${libdir}/named/*.so* ${libdir}/*-${PV}.so" | ||
122 | FILES:${PN}-staticdev += "${libdir}/*.la" | ||
123 | |||
124 | PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-bind', '', d)}" | ||
125 | FILES:python3-bind = "${sbindir}/dnssec-coverage ${sbindir}/dnssec-checkds \ | ||
126 | ${sbindir}/dnssec-keymgr ${PYTHON_SITEPACKAGES_DIR}" | ||
127 | |||
128 | RDEPENDS:${PN}-dev = "" | ||
129 | RDEPENDS:python3-bind = "python3-core python3-ply" | ||