summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.16.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.16.15.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.16.15.bb127
1 files changed, 127 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.16.15.bb b/meta/recipes-connectivity/bind/bind_9.16.15.bb
new file mode 100644
index 0000000000..e362b21294
--- /dev/null
+++ b/meta/recipes-connectivity/bind/bind_9.16.15.bb
@@ -0,0 +1,127 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "https://www.isc.org/bind/"
3DESCRIPTION = "BIND 9 provides a full-featured Domain Name Server system"
4SECTION = "console/network"
5
6LICENSE = "MPL-2.0"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=ef10b4de6371115dcecdc38ca2af4561"
8
9DEPENDS = "openssl libcap zlib libuv"
10
11SRC_URI = "https://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.xz \
12 file://conf.patch \
13 file://named.service \
14 file://bind9 \
15 file://generate-rndc-key.sh \
16 file://make-etc-initd-bind-stop-work.patch \
17 file://init.d-add-support-for-read-only-rootfs.patch \
18 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
19 file://0001-named-lwresd-V-and-start-log-hide-build-options.patch \
20 file://0001-avoid-start-failure-with-bind-user.patch \
21 "
22
23SRC_URI[sha256sum] = "98b6f432d878a7bf8f57eb7b3c28be27278cf6b9989154bfe6c81104b38e7839"
24
25UPSTREAM_CHECK_URI = "https://ftp.isc.org/isc/bind9/"
26# stay at 9.16 follow the ESV versions divisible by 4
27UPSTREAM_CHECK_REGEX = "(?P<pver>9.(16|20|24|28)(\.\d+)+(-P\d+)*)/"
28
29inherit autotools update-rc.d systemd useradd pkgconfig multilib_header update-alternatives
30
31# PACKAGECONFIGs readline and libedit should NOT be set at same time
32PACKAGECONFIG ?= "readline"
33PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--without-libxml2,libxml2"
34PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
35PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
36PACKAGECONFIG[python3] = "--with-python=yes --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native,"
37
38EXTRA_OECONF = " --with-libtool --disable-devpoll --disable-auto-validation --enable-epoll \
39 --with-gssapi=no --with-lmdb=no --with-zlib \
40 --sysconfdir=${sysconfdir}/bind \
41 --with-openssl=${STAGING_DIR_HOST}${prefix} \
42 "
43LDFLAGS_append = " -lz"
44
45inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native distutils3-base', '', d)}
46
47# dhcp needs .la so keep them
48REMOVE_LIBTOOL_LA = "0"
49
50USERADD_PACKAGES = "${PN}"
51USERADD_PARAM_${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \
52 --user-group bind"
53
54INITSCRIPT_NAME = "bind"
55INITSCRIPT_PARAMS = "defaults"
56
57SYSTEMD_SERVICE_${PN} = "named.service"
58
59do_install_append() {
60
61 rmdir "${D}${localstatedir}/run"
62 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
63 install -d -o bind "${D}${localstatedir}/cache/bind"
64 install -d "${D}${sysconfdir}/bind"
65 install -d "${D}${sysconfdir}/init.d"
66 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
67 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
68 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
69 sed -i -e '1s,#!.*python3,#! /usr/bin/python3,' \
70 ${D}${sbindir}/dnssec-coverage \
71 ${D}${sbindir}/dnssec-checkds \
72 ${D}${sbindir}/dnssec-keymgr
73 fi
74
75 # Install systemd related files
76 install -d ${D}${sbindir}
77 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
78 install -d ${D}${systemd_unitdir}/system
79 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
80 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
81 -e 's,@SBINDIR@,${sbindir},g' \
82 ${D}${systemd_unitdir}/system/named.service
83
84 install -d ${D}${sysconfdir}/default
85 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
86
87 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
88 install -d ${D}${sysconfdir}/tmpfiles.d
89 echo "d /run/named 0755 bind bind - -" > ${D}${sysconfdir}/tmpfiles.d/bind.conf
90 fi
91
92 oe_multilib_header isc/platform.h
93}
94
95CONFFILES_${PN} = " \
96 ${sysconfdir}/bind/named.conf \
97 ${sysconfdir}/bind/named.conf.local \
98 ${sysconfdir}/bind/named.conf.options \
99 ${sysconfdir}/bind/db.0 \
100 ${sysconfdir}/bind/db.127 \
101 ${sysconfdir}/bind/db.empty \
102 ${sysconfdir}/bind/db.local \
103 ${sysconfdir}/bind/db.root \
104 "
105
106ALTERNATIVE_${PN}-utils = "nslookup"
107ALTERNATIVE_LINK_NAME[nslookup] = "${bindir}/nslookup"
108ALTERNATIVE_PRIORITY = "100"
109
110PACKAGE_BEFORE_PN += "${PN}-utils"
111FILES_${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/mdig ${bindir}/nslookup ${bindir}/nsupdate"
112FILES_${PN}-dev += "${bindir}/isc-config.h"
113FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
114
115PACKAGE_BEFORE_PN += "${PN}-libs"
116# special arrangement below due to
117# https://github.com/isc-projects/bind9/commit/0e25af628cd776f98c04fc4cc59048f5448f6c88
118FILES_SOLIBSDEV = "${libdir}/*[!0-9].so ${libdir}/libbind9.so"
119FILES_${PN}-libs = "${libdir}/named/*.so* ${libdir}/*-${PV}.so"
120FILES_${PN}-staticdev += "${libdir}/*.la"
121
122PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-bind', '', d)}"
123FILES_python3-bind = "${sbindir}/dnssec-coverage ${sbindir}/dnssec-checkds \
124 ${sbindir}/dnssec-keymgr ${PYTHON_SITEPACKAGES_DIR}"
125
126RDEPENDS_${PN}-dev = ""
127RDEPENDS_python3-bind = "python3-core python3-ply"