summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/bind/bind_9.11.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.11.22.bb')
-rw-r--r--meta/recipes-connectivity/bind/bind_9.11.22.bb140
1 files changed, 0 insertions, 140 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.11.22.bb b/meta/recipes-connectivity/bind/bind_9.11.22.bb
deleted file mode 100644
index 3b4a299b36..0000000000
--- a/meta/recipes-connectivity/bind/bind_9.11.22.bb
+++ /dev/null
@@ -1,140 +0,0 @@
1SUMMARY = "ISC Internet Domain Name Server"
2HOMEPAGE = "https://www.isc.org/bind/"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=bf39058a7f64b2a934ce14dc9ec1dd45"
7
8DEPENDS = "openssl libcap zlib"
9
10SRC_URI = "https://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \
11 file://conf.patch \
12 file://named.service \
13 file://bind9 \
14 file://generate-rndc-key.sh \
15 file://make-etc-initd-bind-stop-work.patch \
16 file://init.d-add-support-for-read-only-rootfs.patch \
17 file://bind-ensure-searching-for-json-headers-searches-sysr.patch \
18 file://0001-configure.in-remove-useless-L-use_openssl-lib.patch \
19 file://0001-named-lwresd-V-and-start-log-hide-build-options.patch \
20 file://0001-avoid-start-failure-with-bind-user.patch \
21 "
22
23SRC_URI[sha256sum] = "afc6d8015006f1cabf699ff19f517bb8fd9c1811e5231f26baf51c3550262ac9"
24
25UPSTREAM_CHECK_URI = "https://ftp.isc.org/isc/bind9/"
26# stay at 9.11 until 9.16, from 9.16 follow the ESV versions divisible by 4
27UPSTREAM_CHECK_REGEX = "(?P<pver>9.(11|16|20|24|28)(\.\d+)+(-P\d+)*)/"
28
29# BIND >= 9.11.2 need dhcpd >= 4.4.0,
30# don't report it here since dhcpd is already recent enough.
31CVE_CHECK_WHITELIST += "CVE-2019-6470"
32
33inherit autotools update-rc.d systemd useradd pkgconfig multilib_script multilib_header
34
35MULTILIB_SCRIPTS = "${PN}:${bindir}/bind9-config ${PN}:${bindir}/isc-config.sh"
36
37# PACKAGECONFIGs readline and libedit should NOT be set at same time
38PACKAGECONFIG ?= "readline"
39PACKAGECONFIG[httpstats] = "--with-libxml2=${STAGING_DIR_HOST}${prefix},--without-libxml2,libxml2"
40PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline"
41PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit"
42PACKAGECONFIG[urandom] = "--with-randomdev=/dev/urandom,--with-randomdev=/dev/random,,"
43PACKAGECONFIG[python3] = "--with-python=yes --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} , --without-python, python3-ply-native,"
44
45ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}"
46EXTRA_OECONF = " ${ENABLE_IPV6} --with-libtool --enable-threads \
47 --disable-devpoll --enable-epoll --with-gost=no \
48 --with-gssapi=no --with-ecdsa=yes --with-eddsa=no \
49 --with-lmdb=no \
50 --sysconfdir=${sysconfdir}/bind \
51 --with-openssl=${STAGING_DIR_HOST}${prefix} \
52 "
53
54inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native distutils3-base', '', d)}
55
56# dhcp needs .la so keep them
57REMOVE_LIBTOOL_LA = "0"
58
59USERADD_PACKAGES = "${PN}"
60USERADD_PARAM_${PN} = "--system --home ${localstatedir}/cache/bind --no-create-home \
61 --user-group bind"
62
63INITSCRIPT_NAME = "bind"
64INITSCRIPT_PARAMS = "defaults"
65
66SYSTEMD_SERVICE_${PN} = "named.service"
67
68do_install_prepend() {
69 # clean host path in isc-config.sh before the hardlink created
70 # by "make install":
71 # bind9-config -> isc-config.sh
72 sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh
73}
74
75do_install_append() {
76
77 rmdir "${D}${localstatedir}/run"
78 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
79 install -d -o bind "${D}${localstatedir}/cache/bind"
80 install -d "${D}${sysconfdir}/bind"
81 install -d "${D}${sysconfdir}/init.d"
82 install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/"
83 install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind"
84 if ${@bb.utils.contains('PACKAGECONFIG', 'python3', 'true', 'false', d)}; then
85 sed -i -e '1s,#!.*python3,#! /usr/bin/python3,' \
86 ${D}${sbindir}/dnssec-coverage \
87 ${D}${sbindir}/dnssec-checkds \
88 ${D}${sbindir}/dnssec-keymgr
89 fi
90
91 # Install systemd related files
92 install -d ${D}${sbindir}
93 install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir}
94 install -d ${D}${systemd_unitdir}/system
95 install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system
96 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
97 -e 's,@SBINDIR@,${sbindir},g' \
98 ${D}${systemd_unitdir}/system/named.service
99
100 install -d ${D}${sysconfdir}/default
101 install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default
102
103 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
104 install -d ${D}${sysconfdir}/tmpfiles.d
105 echo "d /run/named 0755 bind bind - -" > ${D}${sysconfdir}/tmpfiles.d/bind.conf
106 fi
107
108 oe_multilib_header isc/platform.h
109}
110
111CONFFILES_${PN} = " \
112 ${sysconfdir}/bind/named.conf \
113 ${sysconfdir}/bind/named.conf.local \
114 ${sysconfdir}/bind/named.conf.options \
115 ${sysconfdir}/bind/db.0 \
116 ${sysconfdir}/bind/db.127 \
117 ${sysconfdir}/bind/db.empty \
118 ${sysconfdir}/bind/db.local \
119 ${sysconfdir}/bind/db.root \
120 "
121
122ALTERNATIVE_${PN}-utils = "nslookup"
123ALTERNATIVE_LINK_NAME[nslookup] = "${bindir}/nslookup"
124ALTERNATIVE_PRIORITY = "100"
125
126PACKAGE_BEFORE_PN += "${PN}-utils"
127FILES_${PN}-utils = "${bindir}/host ${bindir}/dig ${bindir}/mdig ${bindir}/nslookup ${bindir}/nsupdate"
128FILES_${PN}-dev += "${bindir}/isc-config.h"
129FILES_${PN} += "${sbindir}/generate-rndc-key.sh"
130
131PACKAGE_BEFORE_PN += "${PN}-libs"
132FILES_${PN}-libs = "${libdir}/*.so*"
133FILES_${PN}-staticdev += "${libdir}/*.la"
134
135PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3-bind', '', d)}"
136FILES_python3-bind = "${sbindir}/dnssec-coverage ${sbindir}/dnssec-checkds \
137 ${sbindir}/dnssec-keymgr ${PYTHON_SITEPACKAGES_DIR}"
138
139RDEPENDS_${PN}-dev = ""
140RDEPENDS_python3-bind = "python3-core python3-ply"