diff options
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.10.3-P2.bb')
-rw-r--r-- | meta/recipes-connectivity/bind/bind_9.10.3-P2.bb | 106 |
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.10.3-P2.bb b/meta/recipes-connectivity/bind/bind_9.10.3-P2.bb new file mode 100644 index 0000000000..875a0c8f80 --- /dev/null +++ b/meta/recipes-connectivity/bind/bind_9.10.3-P2.bb | |||
@@ -0,0 +1,106 @@ | |||
1 | SUMMARY = "ISC Internet Domain Name Server" | ||
2 | HOMEPAGE = "http://www.isc.org/sw/bind/" | ||
3 | SECTION = "console/network" | ||
4 | |||
5 | LICENSE = "ISC & BSD" | ||
6 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=0a95f52a0ab6c5f52dedc9a45e7abb3f" | ||
7 | |||
8 | DEPENDS = "openssl libcap" | ||
9 | |||
10 | SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \ | ||
11 | file://conf.patch \ | ||
12 | file://make-etc-initd-bind-stop-work.patch \ | ||
13 | file://mips1-not-support-opcode.diff \ | ||
14 | file://dont-test-on-host.patch \ | ||
15 | file://generate-rndc-key.sh \ | ||
16 | file://named.service \ | ||
17 | file://bind9 \ | ||
18 | file://init.d-add-support-for-read-only-rootfs.patch \ | ||
19 | file://bind-confgen-build-unix.o-once.patch \ | ||
20 | file://0001-build-use-pkg-config-to-find-libxml2.patch \ | ||
21 | file://bind-ensure-searching-for-json-headers-searches-sysr.patch \ | ||
22 | file://0001-gen.c-extend-DIRNAMESIZE-from-256-to-512.patch \ | ||
23 | file://0001-lib-dns-gen.c-fix-too-long-error.patch \ | ||
24 | " | ||
25 | |||
26 | SRC_URI[md5sum] = "672dd3c2796b12ac8440f55bcaecfa82" | ||
27 | SRC_URI[sha256sum] = "4a6c1911ac0d4b6be635b63de3429b6c168ea244043f12bbc8a4eb3368fd6ecd" | ||
28 | |||
29 | ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}" | ||
30 | EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \ | ||
31 | --disable-devpoll --disable-epoll --with-gost=no \ | ||
32 | --with-gssapi=no --with-ecdsa=yes \ | ||
33 | --sysconfdir=${sysconfdir}/bind \ | ||
34 | --with-openssl=${STAGING_LIBDIR}/.. \ | ||
35 | " | ||
36 | inherit autotools update-rc.d systemd useradd pkgconfig | ||
37 | |||
38 | # PACKAGECONFIGs readline and libedit should NOT be set at same time | ||
39 | PACKAGECONFIG ?= "readline" | ||
40 | PACKAGECONFIG[httpstats] = "--with-libxml2,--without-libxml2,libxml2" | ||
41 | PACKAGECONFIG[readline] = "--with-readline=-lreadline,,readline" | ||
42 | PACKAGECONFIG[libedit] = "--with-readline=-ledit,,libedit" | ||
43 | |||
44 | USERADD_PACKAGES = "${PN}" | ||
45 | USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \ | ||
46 | --user-group bind" | ||
47 | |||
48 | INITSCRIPT_NAME = "bind" | ||
49 | INITSCRIPT_PARAMS = "defaults" | ||
50 | |||
51 | SYSTEMD_SERVICE_${PN} = "named.service" | ||
52 | |||
53 | PARALLEL_MAKE = "" | ||
54 | |||
55 | RDEPENDS_${PN} = "python-core" | ||
56 | RDEPENDS_${PN}-dev = "" | ||
57 | |||
58 | PACKAGE_BEFORE_PN += "${PN}-utils" | ||
59 | FILES_${PN}-utils = "${bindir}/host ${bindir}/dig" | ||
60 | FILES_${PN}-dev += "${bindir}/isc-config.h" | ||
61 | FILES_${PN} += "${sbindir}/generate-rndc-key.sh" | ||
62 | |||
63 | do_install_prepend() { | ||
64 | # clean host path in isc-config.sh before the hardlink created | ||
65 | # by "make install": | ||
66 | # bind9-config -> isc-config.sh | ||
67 | sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh | ||
68 | } | ||
69 | |||
70 | do_install_append() { | ||
71 | rm "${D}${bindir}/nslookup" | ||
72 | rm "${D}${mandir}/man1/nslookup.1" | ||
73 | rmdir "${D}${localstatedir}/run" | ||
74 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | ||
75 | install -d "${D}${localstatedir}/cache/bind" | ||
76 | install -d "${D}${sysconfdir}/bind" | ||
77 | install -d "${D}${sysconfdir}/init.d" | ||
78 | install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/" | ||
79 | install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind" | ||
80 | sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds | ||
81 | |||
82 | # Install systemd related files | ||
83 | install -d ${D}${localstatedir}/cache/bind | ||
84 | install -d ${D}${sbindir} | ||
85 | install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir} | ||
86 | install -d ${D}${systemd_unitdir}/system | ||
87 | install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system | ||
88 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
89 | -e 's,@SBINDIR@,${sbindir},g' \ | ||
90 | ${D}${systemd_unitdir}/system/named.service | ||
91 | |||
92 | install -d ${D}${sysconfdir}/default | ||
93 | install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default | ||
94 | } | ||
95 | |||
96 | CONFFILES_${PN} = " \ | ||
97 | ${sysconfdir}/bind/named.conf \ | ||
98 | ${sysconfdir}/bind/named.conf.local \ | ||
99 | ${sysconfdir}/bind/named.conf.options \ | ||
100 | ${sysconfdir}/bind/db.0 \ | ||
101 | ${sysconfdir}/bind/db.127 \ | ||
102 | ${sysconfdir}/bind/db.empty \ | ||
103 | ${sysconfdir}/bind/db.local \ | ||
104 | ${sysconfdir}/bind/db.root \ | ||
105 | " | ||
106 | |||