diff options
Diffstat (limited to 'meta/recipes-connectivity/bind/bind_9.10.2-P4.bb')
-rw-r--r-- | meta/recipes-connectivity/bind/bind_9.10.2-P4.bb | 101 |
1 files changed, 101 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb b/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb new file mode 100644 index 0000000000..66616b8d08 --- /dev/null +++ b/meta/recipes-connectivity/bind/bind_9.10.2-P4.bb | |||
@@ -0,0 +1,101 @@ | |||
1 | SUMMARY = "ISC Internet Domain Name Server" | ||
2 | HOMEPAGE = "http://www.isc.org/sw/bind/" | ||
3 | SECTION = "console/network" | ||
4 | |||
5 | LICENSE = "ISC & BSD" | ||
6 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=0a95f52a0ab6c5f52dedc9a45e7abb3f" | ||
7 | |||
8 | DEPENDS = "openssl libcap" | ||
9 | |||
10 | SRC_URI = "ftp://ftp.isc.org/isc/bind9/${PV}/${BPN}-${PV}.tar.gz \ | ||
11 | file://conf.patch \ | ||
12 | file://make-etc-initd-bind-stop-work.patch \ | ||
13 | file://mips1-not-support-opcode.diff \ | ||
14 | file://dont-test-on-host.patch \ | ||
15 | file://generate-rndc-key.sh \ | ||
16 | file://named.service \ | ||
17 | file://bind9 \ | ||
18 | file://init.d-add-support-for-read-only-rootfs.patch \ | ||
19 | file://bind-confgen-build-unix.o-once.patch \ | ||
20 | file://0001-build-use-pkg-config-to-find-libxml2.patch \ | ||
21 | file://bind-ensure-searching-for-json-headers-searches-sysr.patch \ | ||
22 | " | ||
23 | |||
24 | SRC_URI[md5sum] = "8b1f5064837756c938eadc1537dec5c7" | ||
25 | SRC_URI[sha256sum] = "c00b21ec1def212957f28efe9d10aac52d6ec515e84fbf2c42143f5d71429cb8" | ||
26 | |||
27 | ENABLE_IPV6 = "--enable-ipv6=${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'yes', 'no', d)}" | ||
28 | EXTRA_OECONF = " ${ENABLE_IPV6} --with-randomdev=/dev/random --disable-threads \ | ||
29 | --disable-devpoll --disable-epoll --with-gost=no \ | ||
30 | --with-gssapi=no --with-ecdsa=yes \ | ||
31 | --sysconfdir=${sysconfdir}/bind \ | ||
32 | --with-openssl=${STAGING_LIBDIR}/.. \ | ||
33 | " | ||
34 | inherit autotools update-rc.d systemd useradd pkgconfig | ||
35 | |||
36 | PACKAGECONFIG ?= "" | ||
37 | PACKAGECONFIG[httpstats] = "--with-libxml2,--without-libxml2,libxml2" | ||
38 | |||
39 | USERADD_PACKAGES = "${PN}" | ||
40 | USERADD_PARAM_${PN} = "--system --home /var/cache/bind --no-create-home \ | ||
41 | --user-group bind" | ||
42 | |||
43 | INITSCRIPT_NAME = "bind" | ||
44 | INITSCRIPT_PARAMS = "defaults" | ||
45 | |||
46 | SYSTEMD_SERVICE_${PN} = "named.service" | ||
47 | |||
48 | PARALLEL_MAKE = "" | ||
49 | |||
50 | RDEPENDS_${PN} = "python-core" | ||
51 | RDEPENDS_${PN}-dev = "" | ||
52 | |||
53 | PACKAGE_BEFORE_PN += "${PN}-utils" | ||
54 | FILES_${PN}-utils = "${bindir}/host ${bindir}/dig" | ||
55 | FILES_${PN}-dev += "${bindir}/isc-config.h" | ||
56 | FILES_${PN} += "${sbindir}/generate-rndc-key.sh" | ||
57 | |||
58 | do_install_prepend() { | ||
59 | # clean host path in isc-config.sh before the hardlink created | ||
60 | # by "make install": | ||
61 | # bind9-config -> isc-config.sh | ||
62 | sed -i -e "s,${STAGING_LIBDIR},${libdir}," ${B}/isc-config.sh | ||
63 | } | ||
64 | |||
65 | do_install_append() { | ||
66 | rm "${D}${bindir}/nslookup" | ||
67 | rm "${D}${mandir}/man1/nslookup.1" | ||
68 | rmdir "${D}${localstatedir}/run" | ||
69 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" | ||
70 | install -d "${D}${localstatedir}/cache/bind" | ||
71 | install -d "${D}${sysconfdir}/bind" | ||
72 | install -d "${D}${sysconfdir}/init.d" | ||
73 | install -m 644 ${S}/conf/* "${D}${sysconfdir}/bind/" | ||
74 | install -m 755 "${S}/init.d" "${D}${sysconfdir}/init.d/bind" | ||
75 | sed -i -e '1s,#!.*python,#! /usr/bin/env python,' ${D}${sbindir}/dnssec-coverage ${D}${sbindir}/dnssec-checkds | ||
76 | |||
77 | # Install systemd related files | ||
78 | install -d ${D}${localstatedir}/cache/bind | ||
79 | install -d ${D}${sbindir} | ||
80 | install -m 755 ${WORKDIR}/generate-rndc-key.sh ${D}${sbindir} | ||
81 | install -d ${D}${systemd_unitdir}/system | ||
82 | install -m 0644 ${WORKDIR}/named.service ${D}${systemd_unitdir}/system | ||
83 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
84 | -e 's,@SBINDIR@,${sbindir},g' \ | ||
85 | ${D}${systemd_unitdir}/system/named.service | ||
86 | |||
87 | install -d ${D}${sysconfdir}/default | ||
88 | install -m 0644 ${WORKDIR}/bind9 ${D}${sysconfdir}/default | ||
89 | } | ||
90 | |||
91 | CONFFILES_${PN} = " \ | ||
92 | ${sysconfdir}/bind/named.conf \ | ||
93 | ${sysconfdir}/bind/named.conf.local \ | ||
94 | ${sysconfdir}/bind/named.conf.options \ | ||
95 | ${sysconfdir}/bind/db.0 \ | ||
96 | ${sysconfdir}/bind/db.127 \ | ||
97 | ${sysconfdir}/bind/db.empty \ | ||
98 | ${sysconfdir}/bind/db.local \ | ||
99 | ${sysconfdir}/bind/db.root \ | ||
100 | " | ||
101 | |||