summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/zaurus-updater/encdec-updater.bb')
-rw-r--r--meta/recipes-bsp/zaurus-updater/encdec-updater.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-bsp/zaurus-updater/encdec-updater.bb b/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
new file mode 100644
index 0000000000..c59d0e2976
--- /dev/null
+++ b/meta/recipes-bsp/zaurus-updater/encdec-updater.bb
@@ -0,0 +1,18 @@
1SECTION = "console/utils"
2LICENSE = "GPL"
3DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
4
5SRC_URI = "file://encdec-updater.c"
6
7COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
8
9do_compile() {
10 ${CC} -o encdec-updater ${WORKDIR}/encdec-updater.c
11}
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 encdec-updater ${D}${bindir}/
16}
17
18BBCLASSEXTEND = "native" \ No newline at end of file