summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/v86d/v86d_0.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/v86d/v86d_0.1.9.bb')
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.9.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.9.bb b/meta/recipes-bsp/v86d/v86d_0.1.9.bb
new file mode 100644
index 0000000000..19510b9348
--- /dev/null
+++ b/meta/recipes-bsp/v86d/v86d_0.1.9.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "User support binary for the uvesafb kernel module"
2HOMEPAGE = "http://dev.gentoo.org/~spock/projects/uvesafb/"
3
4LICENSE = "GPLv2"
5
6DEPENDS = "virtual/kernel"
7RRECOMMENDS_${PN} = "kernel-module-uvesafb"
8PR = "r0"
9
10SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
11 file://fbsetup"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14COMPATIBLE_MACHINE = "(qemux86|bootcdx86)"
15
16INITSCRIPT_NAME = "fbsetup"
17INITSCRIPT_PARAMS = "start 0 S ."
18
19do_configure () {
20 ./configure --with-x86emu
21}
22
23do_compile () {
24 KDIR="${STAGING_KERNEL_DIR}" make
25}
26
27do_install () {
28 install -d ${D}${base_sbindir}
29 install v86d ${D}${base_sbindir}/
30
31 install -d ${D}${sysconfdir}/init.d/
32 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
33}
34
35inherit update-rc.d